7i73 LCD shows rubisch

More
07 Mar 2018 19:16 #107092 by andypugh
Replied by andypugh on topic 7i73 LCD shows rubisch
Great! That's a real relief.

It also means I can put the 7i73 back in my milling machine and get that working again :-)

(It is broken in other ways, not just because I borrowed the 7i73)

Please Log in or Create an account to join the conversation.

More
07 Mar 2018 20:13 #107093 by Mike_Eitel
Replied by Mike_Eitel on topic 7i73 LCD shows rubisch
Let's not forget, also one of the changes you made changed the screen.
I have the feeling that there was more than one bug involved.

Anyhow, super engaged work.
I would love to see such engagement on some of our suppliers daily working ;-(

Thx Mike

Please Log in or Create an account to join the conversation.

More
03 May 2019 15:03 - 03 May 2019 15:23 #132639 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
Hello,
Someone trying to connect an OLED display on a 7i73 ?
I rated 1 LCD display and 1 OLED with Arduino, both are working (but rows permutated on oled )
But on the 7i73 the LCD works but not the OLED
thank you

Linuxcnc 2.7.14 5i20 SVSS4_8
www.lcd-module.com/fileadmin/eng/pdf/doma/olede.pdf
(it's the same as the NHD-0420DZW-AG5)
Last edit: 03 May 2019 15:23 by gaston48.

Please Log in or Create an account to join the conversation.

More
03 May 2019 15:52 #132643 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
I wonder if there is some initialization code needed on the OLED display
do any commands like clear screen work?

Please Log in or Create an account to join the conversation.

More
03 May 2019 16:48 #132648 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
thank you PCW,

I do not know, I use Andy's "lcd" there
has no clear screnn instruction.
With arduino, oled and lcd start at power on

I have 2 new 7i73 unit the display is different under the same conditions ?
unit 1300010A
unit 13000168

Please Log in or Create an account to join the conversation.

More
03 May 2019 17:33 #132653 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
Yeah, the display looks random though all 7I73s since 2013 have the same firmware.

Clear screen is ASCII 0x1A

Please Log in or Create an account to join the conversation.

More
03 May 2019 20:37 #132665 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
Ok, I saw that we can send control characters with lcd component "\HH"

I sent 0x1A, 0x0D also, not really effect, it changes the random side.
I forgot to mention that the display is also very animated !

Please Log in or Create an account to join the conversation.

More
03 May 2019 21:21 #132668 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
Yeah maybe the OLED controller is not close enough to the LCD controllers to work properly with the 7I73 signals. We did verify operation with many LCDs
but (relativley) low cost OLEDS were not available at the time we did the testing.

Please Log in or Create an account to join the conversation.

More
04 May 2019 10:24 #132715 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
Just thought of something: how are you powering the OLED?

A LCD would be connected to the 7I73s VEE pin but this wont work with the OLED
Have you tried 5V and 3.3V power from the 7I73?

Please Log in or Create an account to join the conversation.

More
04 May 2019 13:53 #132737 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
By the 5 V of the pin 28 and the GND pin 27. VEE not connected

I suspected the power supply and I checked
with an oscillo the power supply is clean

the funny thing is that when I send a fixed text
the oled sometimes returns an animated light of nignt club :)

An oled display is truly incomparable for a
industrial application: readability in all angles, contrast, time response etc ...

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.218 seconds
Powered by Kunena Forum