7i73 LCD shows rubisch

More
17 May 2019 00:58 - 17 May 2019 00:58 #134022 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
As a data point, a NewHaven NHD-0420DZW-AG5 OLED works fine with the 7I73
(the G means Green, the other colors should be OK also)

It requires 3.3V VDD or 1 diode drop in VDD from 5V

Contrary to the data sheet suggestion, we did have to ground the LCD D0..D3 pins for consistent behavior

You also need to make sure the display is powered up when the 7I73 is powered up so the 7I73 display initialization is done.
Last edit: 17 May 2019 00:58 by PCW.

Please Log in or Create an account to join the conversation.

More
17 May 2019 16:18 #134058 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
thanks for the tests.
You tested with the Andy lcd.comp component?

I test my oled again with d0 to d3 at the ground
but unfortunately I still blinking the cursor
like my video.

Please Log in or Create an account to join the conversation.

More
17 May 2019 16:25 #134059 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
Yes, tested with the lcd component
No cursor issue

Please Log in or Create an account to join the conversation.

More
17 May 2019 16:50 #134067 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
thank you PCW,
i will try to get an "original new haven"

Please Log in or Create an account to join the conversation.

More
17 May 2019 16:59 #134071 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
I do know that not all NewHaven OLEDs work, I also got a NHD-0420CW-AY3
and its a mess: mirrored text!

Please Log in or Create an account to join the conversation.

More
17 May 2019 17:36 #134080 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
Ok I found one in Spain, :)
I ordered it, I'll keep you informed

have a good weekend !

Please Log in or Create an account to join the conversation.

More
17 May 2019 17:48 #134082 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
If you have the same display, we can compare notes/hal files if there's still an issue

Please Log in or Create an account to join the conversation.

More
17 May 2019 18:33 #134084 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
Yes,
for now, for me, my test stallion is Andy's,
very easy to use
forum.linuxcnc.org/27-driver-boards/3385...isch?start=20#105606

Please Log in or Create an account to join the conversation.

More
26 May 2019 11:13 - 26 May 2019 12:48 #134991 by gaston48
Replied by gaston48 on topic 7i73 LCD shows rubisch
Hello Peter,
I tested the Newhaven, unfortunately it's exactly the same problem
I checked the 3.3 V power supply, it is stable.
At startup, led of 7i73 red a cursor flashes, 1 Hz, in the top left on the oled.
After when the oled is piloted, the cursor remains present and disrupts the display at 1 Hz also.
With two 7i73, with a 5i20 or a 6i24-25.

Attachments:
Last edit: 26 May 2019 12:48 by gaston48.

Please Log in or Create an account to join the conversation.

More
26 May 2019 14:15 - 26 May 2019 14:16 #134999 by PCW
Replied by PCW on topic 7i73 LCD shows rubisch
That sounds like my behavior (display is cleared at power up and you get a blinking cursor in the top left )
except that as soon as the LCD component is loaded, the cursor is turned off.

Have you tried starting the LCD component by hand?

What is your servo thread rate? The OLED is about 50 times slower than the LCD in processing characters
and it might lose characters in some circumstances.
(including the LCD components startup code that turns off the cursor)
Last edit: 26 May 2019 14:16 by PCW.

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.215 seconds
Powered by Kunena Forum