Gcode sharing folder ( Debian / Windows 7)

17 Apr 2018 03:19 #109159 by rodw
Yeh, I moved that command to fstab. and got no errors when testing but after rebooting the folder is empty on startup. Very annoying such a simple thing is so hard.
17 Apr 2018 04:36 #109162 by islander261

Allegedly you need to edit the /ect/fstab file by adding the following line or something close to it with the highlighted text changed to your system:

// /mnt/shares/share1 cifs username=user1name ,password=user1password 0 0


mount.cifs – Mount using the CIFS
// – IP address or name of file server followed by the share name
/mnt/shares/share1/ – This is the mount point where our network share will reside
-o users=user1,password=user1 – This means options and in my case I am specifying the username and password to the share
Mount Public Share

To mount a public share or one that doesn’t require a password is even easier. All you are required to specify is the server IP address, share and mount point.

mount.cifs // /mnt/shares/share1/
mount.cifs – Mount using the CIFS
// – IP address or name of file server followed by share name
/mnt/shares/share1/ – This is the mount point where our network share will reside

You may need this altered some what look at you man pages or online about mounting networked drives. I have not been able to get this this to work at all. I keep getting the notorious error 79 even though I have all of character mapping files installed. Good luck and share what works.

17 Apr 2018 05:16 #109164 by rodw

Thanks, thats exactly what I've done and I get an empty folder
fstab says:
//192.168.1.xxx/home /mnt cifs username=rod,password=xxxxxx 0 0
Actually, I think its a permissions issue as media/ds is owned by root. So now I just have to work out how to give permissions to everybody for the share.
17 Apr 2018 05:51 #109168 by AnnoyingMutt
On my samba server I have a share such as:

comment = Public Share
path = /path/to/share
browsable = yes
guest ok = yes
force group = somebody
writable = yes
create mask = 0755

Ok for home use but not totally secure

For that folder the owner and group are somebody somebody permissions are 42775 (there was a reason for that)

I can log in with any valid samba user name and all files are owned by somebody

There was an issue when I upgrade from slackware 10.2 to 14.2 with the config but I think it was with the force owner parameter, which I don't use now. It was a while ago.
17 Apr 2018 18:46 #109217 by islander261

Thanks ozzyrob for the input. Reading about Samba Server helped some.

This is all way over my head as we dive deep into Linux land. Google was my friend here as I blindly followed instructions. There seem to be about a millon options and combinations of option that can be needed to make this work if you do the man pages for mount and mount.cifs, which was already installed on my system from my original install of LDME2 Cinnamon 64bit.

I did manage to make mine work even after reboot. I seems that even though the character coding files are installed the option that specified the character coding is what caused my problem, error 79, originally.

I had to create a directory for the link to be in.

So I had to install winbind, Look it up on line, to maybe read the WINS info on my home workgroup? Then I restarted my system after shutting it down.

I had to create a file in my home directory .smbcredentails that contains two lines for each user:

Then I added the following line as a single line to the /etc/fstab file:

// /media/mybook cifs credentials=/home/jd/.smbcredentials,gid=jd,uid=jd,file_mode=0777,dir_mode=0777 0 0

Your actual settings will be for your system.

Then I did this:

sudo mount -a

When this ran it put shortcut on my desktop (LMDE2 Cinnamon) and had the linked device files in the directory I created.

I have shut down my system and restarted it several times and the shortcut and files are still there.

14 May 2018 17:28 #110733 by allenwg2005
I had the same question on installing Dropbox, I did a search and found this thread.

An answer to installing Dropbox seemed to get lost in all the other options.

So is Dropbox not an option in LCNC?
(What a simple way to share files, I have numerous machines with MS OS and Linux sharing via Dropbox, but not LCNC).

All the acronyms and techy mumbo jumbo leads me to believe sharing two PC's one with LinuxCNC the other with Win7 is a long drawn out pain in the .....!
Especially if you just 'use' computers as opposed to being a computer scientist (or are someone with way more time on their hands than I have).
14 May 2018 19:53 #110737 by AnnoyingMutt
Have you tried searching google with the phrase:

dropbox debian wheezy

Sorry if this post contains too much techno mumbo jumbo

As mentioned before winscp is a very good option. ssh runs out the box on debian.
The following user(s) said Thank You: allenwg2005
14 May 2018 23:00 #110748 by allenwg2005
Mumbo jumbo works for ya if you speak it, it just looks like Latin to me.

Who do you use for a "Host", when on WinSCP?
14 May 2018 23:40 #110749 by AnnoyingMutt
You can try the Help menu


Here's the manual:

If you can't be bothered to learn terms I'd suggest you use Mach3/4, it seems to be more suited to a user with limited time as you claim to have.
15 May 2018 13:14 #110763 by Todd Zuercher
Networking in general can be very frustrating for the uninitiated. Personally, I have more networking problems with Windows machines than Linux. In Windows networking can be very easy, or excruciating, depending on whether or not you are doing things the way Microsoft intended or not. Generally networking in Linux works better, but you need to know how to configure it, or how to look up how to do it.

We store all of our Machine's g-code files on a NAS share (more mumbo jumbo I know get over it), and access them on the Linuxcnc machines by mounting that share with CIFS or Samba. Usually I use a command line in the FSTAB file (a configuration file on the Linuxcnc machine) that permanently mounts the network share as a directory on the Linuxcnc machine. Instructions for doing this are easily googled. I usually have to look them up anytime I set up a new machine.
The following user(s) said Thank You: allenwg2005
Time to create page: 0.091 seconds
Powered by Kunena Forum