PID issues or calibration help

More
13 Jan 2019 19:58 #124101 by hatch789
OK I also had an issue with my signal balance on the analog drive it was turned up too high. Now I move at my max rate on the machine when I'm around +/- 9.8v

The screenshot below is from a fairly rapid move 6v and so it's a pretty good indication of my ferror.

I can't seem to flatten it out anymore no matter what I try. Suggestions welcome
Attachments:
More
13 Jan 2019 20:16 #124104 by PCW
Replied by PCW on topic PID issues or calibration help
Periodic errors like this often point to an overdriven resolver interface (more than 1V on sine or cosine is over driven)

There are a couple of options here

1. Move X,Y,Z to resolver inputs 3,4,5 (and change hal file accordingly) and move drive jumper W2 down
2. Add a divider resistor pair to the drive signal to drop it slightly (say 2x 470 Ohm)
More
13 Jan 2019 20:25 - 13 Jan 2019 20:26 #124105 by hatch789
I did read about that ability of the card to drive at 1/2 the value for channels 3, 4 & 5, but it would be a pain in the ass to move all those wires and everything around.

I think I'll just add a simple in-line resistor as you imply. So let's just look at X in my example below. I'll of course do the same after I test with X but for now I'll just focus on 1 driver to see if it gets me to the desired results.

The driver has 2 pins for the resolver a signal and a common for lack of better terms. I would think that I just want to put 1 resistor in line on the signal wire; a 470 Ohm as you suggest. But please correct me if I'm wrong.

When I was looking at my o-scope for the resolvers over the past 2 days. The SIN and COS signals were very fuzzy (noisy?) as opposed to the signal (driver) loop. So maybe that's also an indication of things being overdriven?
Last edit: 13 Jan 2019 20:26 by hatch789.
More
13 Jan 2019 20:35 #124106 by PCW
Replied by PCW on topic PID issues or calibration help
1. It should be easy to move the resolvers around since each resolver should be on a single 8 terminal plug
2. You will not be able to see the sine/cosine signals very well without a differential (common mode noise rejecting) scope input.
More
13 Jan 2019 20:42 #124107 by hatch789
Yeah I thought about that after I replied ...just move the whole block of 8 pins. Should I also move the signal blocks back from P4 to P3 so that everything is lined up again?

Also I realized if I put a resistor in I would want it in parallel with the driver coil so that resistor would actually go across the 2 pins for the driver coil sharing some of the voltage the the driver originally got and thereby reducing the voltage making it to the driver coil. Is that what you really meant?
More
13 Jan 2019 21:12 #124109 by PCW
Replied by PCW on topic PID issues or calibration help
If you use a single resistor, I would put in series with the drive coil
More
14 Jan 2019 13:12 #124153 by hatch789
I'll see about moving my X resolver block over to the P3 row today and let you know how that affects things after I set that row to half power with the jumper.

Question for you guys on a different note. Is there a way to map keys (such as S) from the keyboard out to my gamepad? Right now I can jog and move my bed with my gamepad but when I have a PAUSE in my gcode I have to go to my keyboard to press S and it would be nice to map that to a button on the gamepad.
More
14 Jan 2019 15:29 #124159 by Todd Zuercher
There are halui pins that can be mapped to things like that. (halui.program.pause)
linuxcnc.org/docs/html/man/man1/halui.1.html
More
17 Jan 2019 01:48 - 17 Jan 2019 02:39 #124313 by hatch789
I got my gamepad working to RESUME a paused program so that's great! Thanks for the tips.

Now guys (probably PCW?) I need help here. I have moved my 8-pin blocks around on my 7i49 resolver card. So everything 00 became 04 and 01 became 05

I also changed the jumper pin W2 to the lower pins to cut the output in half for resolvers 4,5,6

Example of what I did in my Tree.hal file. But I'm getting an error so I think I need to change something else. I left my signals on AOUT0 and AOUT1 so those are still the same.

Something is not happy. My error is this:

Debug file information:
Note: Using POSIX realtime
./Tree.hal:93: parameter or pin 'hm2_7i43.0.resolver.04.velocity-scale' not found
2365
PID TTY STAT TIME COMMAND
Stopping realtime threads
Unloading hal components
Note: Using POSIX realtime



Here's my setup changed 00 to 04 in the cases below

# ---PWM Generator signals/setup---

setp hm2_7i43.0.pwmgen.04.output-type 2
setp hm2_7i43.0.pwmgen.04.scale [AXIS_0]OUTPUT_SCALE

net x-output => hm2_7i43.0.pwmgen.04.value
net x-pos-cmd axis.0.motor-pos-cmd
net x-enable axis.0.amp-enable-out => hm2_7i43.0.pwmgen.04.enable

# ---Resolver feedback signals/setup---

setp hm2_7i43.0.resolver.04.velocity-scale 1 # motor speed in RPS
setp hm2_7i43.0.resolver.04.scale [AXIS_0]RESOLVER_SCALE

net x-pos-rawcounts <= hm2_7i43.0.resolver.04.rawcounts
net x-pos-fb <= hm2_7i43.0.resolver.04.position
net x-vel-fb <= hm2_7i43.0.resolver.04.velocity
net x-pos-fb => axis.0.motor-pos-fb
net x-index-enable axis.0.index-enable <=> hm2_7i43.0.resolver.04.index-enable


nevermind I found the issue
My num_resolvers=3 (at the top of the file) was the problem
When I set this up to 6 that solved the problem. Starting from 00 = 1, by the time you get to 05 that =6 resolvers
Last edit: 17 Jan 2019 02:39 by hatch789.
More
17 Jan 2019 04:03 #124317 by hatch789
well I got rid of my error but I can't move my servos. The signals coming out of AOUT0 and AOUT1 are dead.

I'm trying to determine what parameter I need to change to fix this but I can't seem to find it in the .hal file. My suspicion is that it's PNCCONF or the SVRM6_48.PIN file in my firmware folder. At this point my issue seems to be something small, just misconfigured.
Time to create page: 0.124 seconds
Powered by Kunena Forum