Complete HOW-TO Linux Mint 18.1 32/64 RTAI or PREEMPT with RIP install or deb

More
27 Jul 2017 14:10 #96567 by andypugh

chrisrusk wrote: The Debian Stetch image seems tempting, if not a little unstable?


It shouldn't be unstable, it is a released version of Linux combined with a released version of LinuxCNC.

(albeit a version with a known bug, all G-code errors are reported as "file not found")
More
10 Aug 2017 14:53 #97295 by skrap58
Hi,

I followed this guide to install linuxcnc on ubuntu 16.04 32 bit and it seems to install ok but I cannot figure out how to start linuxcnc.
./linuxcnc = no such file or directory
cd linuxncnc-dev ./ linuxcnc no such file or directory
cd linuxcnc-dev/debian ./linuxcnc is a directory

I am in the 4.1.0-1-rtai-686-pae kernel installed using apt.
What info can i get you that will help me help you solve my problem/

Thanks
Bill
More
10 Aug 2017 21:05 #97318 by rodw

Skrap58 wrote: Hi,

I followed this guide to install linuxcnc on ubuntu 16.04 32 bit and it seems to install ok but I cannot figure out how to start linuxcnc.
./linuxcnc = no such file or directory

Thanks
Bill


Bill, there is a script you must run to set the LCNC environment. See
www.wiki.eusurplus.com/index.php?title=L...c_.28run_in_place.29

Note the extra period is required...
The following user(s) said Thank You: skrap58
More
16 Aug 2017 03:43 #97542 by donnydg
Thank you so much for the time put in to making this guide! It has been a huge help for guys like me that are trying to migrate to Linuxcnc without using Wheezy on some ancient hardware. (Driver support and a pretty interface make all the difference). I've tried going through post 2 several times now and keep getting the same result. When I try to configure my machine, using a 7i76e, I get a diolog box that says:

"You are using a simulated-realtime version of LinuxCNC, so testing / tuning of hardware is unavailable."

What am I missing? I can't help but get the feeling that I'm missing an unwritten step that only super-noobs miss or that the intent of the guide is for simulation only and I missed the memo. Thanks in advance!
More
16 Aug 2017 03:46 #97543 by donnydg
BTW, I'm trying to use Mint 18.2 Cinnamon, the 4.8.11 kernal, with PREEMPT.
More
16 Aug 2017 10:51 #97561 by skrap58
Check this post

www.forum.linuxcnc.org/9-installing-linu...l-on-linux-mint-18-2

I found a real time kernel in synaptic package manager and once it was installed everything worked on LinuxMint 18.2

Bill
More
18 Aug 2017 13:57 - 18 Aug 2017 13:58 #97701 by joel0407
Ok guys, Banging my head against a wall here. 4 attempts at getting this working now. Admittedly I went off the beaten track the first 3 but on my final attempt, I couldn't follow the track.

Attempt 1:
Went with Mint 18.2, Kernel 4.9.40 Fail. Well sort of failed. I didn't work out how to configure the Kernel properly and couldn't find "Fully Preemptable Kernel". It wasn't until the next attempt that I found this. Latency on this attempt ended up going over 1 million. With the old Wheezy install, I got it down to 4000 so I figured I had some head room for the heavier operating system.

Attempt 2:
Mint 18.2, realized Kernel 4.9.4 was confirmed to work not 4.9.40 so this attempt with 4.9.4. Fail

Attempt 3:
Mint 18.1 and Kernel 4.9.4 because 18.2 wasn't exactly confirmed. Fail

Attempt 4:
Just copy and past each command line in order in case I was missing something. Mint 18.1 fresh install. Still Fail

What's really killing me is the Kernel build time is about 3 hours.

Everything works without error until

wget ftp://ftp.kernel.org/pub/linux/kernel/v4.x/linux-4.8.11.tar.xz
wget www.kernel.org/pub/linux/kernel/projects...-4.8.11-rt7.patch.gz

But going to:
The Kernel is located here: kernel.org/pub/linux/kernel/
The RT Patch is located here: kernel.org/pub/linux/kernel/projects/
and downloading the 2 files works fine and I doubt this is my problem. I have tried changing my DNS to google 8.8.8.8 and 8.8.4.4 but wget still doesn't work with those addresses. After downloading I just move the 2 files to my home folder and then uncompress them there.

The next lot all works fine but takes a while. I end up with 5 deb files that I can just open in the gui and install. No problems.

I have never bothered editing the grub menu yet. I have just held left shift during startup and chosen the new Kernel. Confirmed after startup with uname -r.

This: git clone git://git.linuxcnc.org/git/linuxcnc.git linuxcnc-dev has never worked. Don't know why but it can never find the location.

I have just referred to buildbot.linuxcnc.org/ . The last build, I even struggled with this. As far as I got I couldn't cover all the dependencies.

I got this:
The following packages have unmet dependencies:
linux-headers-3.4-9-rtai-686-pae:i386 : Depends: gcc-4.6:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.
Searched and followed along about page 9 on this thread but still couldn't get it. Now I've installed so much stuff, i figure it's just a mess and I'll be starting again for a 5th time.

What got me going on this initially was I had installed a Wifi card and it caused my latency to randomly jump over 100,000. I had a USB WiFi dongle that I couldn't get to work and Rodw mentioned he got his USB dongle working with Mint. When I installed Mint 18.2, mine worked without any extra work from me. What has kept me going at it is I just like how it looks.

I probably shouldn't say I am a noob but I'm going to guess it's been about 12 - 14 years since I build a Linux Kernel and it was a whole lot different then. I've almost always had linux installed on a computer somewhere in the house but there's been times when the computer with Linux might not have been turned on for over 12 months. So not only is it so much different now but I have forgotten so much. As I put in command line commands it comes back to me a little.

I also like everything to be as tidy as it can be. I hate installing something and it not working. I feel that install is always there like rubbish swept under the carpet. I cant see it but I know it's there and I fear it will be slowing something down, whether it is or not? I also like what I install to be the most up to date as it can be. So while I might get the earlier Kernel working, I'll be likely to attempt to start again and get the later Kernel up and running. It's just a personal fault of mine that causes me some grief as I try to get things to work.

I'm currently trying to read all the posts from start to here to make sure I'm not missing something.

Happy Days.
Last edit: 18 Aug 2017 13:58 by joel0407.
More
18 Aug 2017 14:23 #97702 by joel0407
Oh, Reading through the posts now. Next, I'm going off the beaten track again. Going with 18.2 64bit. See what happens.
More
18 Aug 2017 14:37 - 18 Aug 2017 14:42 #97703 by cncnoob1979
Joel

Have you tired a kernel that I have already tested? I have not installed 18.2 but should work about the same.

I successfully had 4.9.4-RT2 kernel to work. That is kernel 4.9.4 with the RT2 patch. The error of downloading the kernel and patch files is because the wget commands are hard linked and they are sometimes moved around the server.

So you end up with an error.

git may not work for you if it is not installed.

try:
sudo apt-get install git
Last edit: 18 Aug 2017 14:42 by cncnoob1979.
More
18 Aug 2017 14:48 - 18 Aug 2017 14:50 #97706 by joel0407
Yep. I only tried 4.9.40 on the first attempt. 4.9.4 for the second and third, 4.8.11 for the forth attempt.

I'll be trying 4.9.4 for the 5th with 18.2 and 64 bit.

Making the install USB now.

It's 10:50pm here and I have to go to work at 4:00am. I just want to get the Kernel building before I go to bed.

Happy Days
Last edit: 18 Aug 2017 14:50 by joel0407.
Time to create page: 0.101 seconds
Powered by Kunena Forum