Complete HOW-TO Linux Mint 18.1 32/64 RTAI or PREEMPT with RIP install or deb

More
31 Oct 2017 18:29 #101079 by cncnoob1979
Yes that's normal for building master. Looks for the ~4mb deb and install it.
More
31 Oct 2017 18:56 #101082 by Todd Zuercher
Yes, when working with a development branch like Master. Until the current Master branch (2.8-pre) is released, that is how it will be numbered. Once it has matured and is released as a stable release, it will be called as 2.8.0, and a new Master branch will be started (likely called 2.9-pre).
More
31 Oct 2017 19:46 - 31 Oct 2017 19:51 #101083 by Thierry
Thanks to you cncnoob1979 and Todd. Unfortunately, the package doesn't install because of dependancies with python2.7-imaging-tk | python-imaging-tk (witch are not installed -> I got the message that 3.1.2.0ubuntu1.1 should be installed to do so). So linuxcnc can't be configured*.
* Those are my personal translations of the french messages..
Since I dowloaded the LiveCd from linuxcnc.org, I wonder if I won't give up with Mint and reinstall the whole system.
Last edit: 31 Oct 2017 19:51 by Thierry. Reason: Correcting typing
More
01 Nov 2017 00:03 #101092 by ozzyrob
Mint is great.....I use it to test various ideas I have for my working machine. Keep with it. It's well worth it.....actually it's a great Desktop Distro.

Actually I now use Linux Mint as my sole OS (Laptop & Desktop, still use slackware for my "Everything" server) after reading and going through the instructions. I'd never used it before reading this thread....and now I'm hooked.
More
01 Nov 2017 07:14 #101100 by Thierry
Hi Ozzyrob,
I'm sure you're right as friends of mine told me the same. But my goal with installing linux is only to work with linuxCNC (the PC on witch I install it is dedicated and has a parallel port). I'm just clever enough with Linux to follow a tutorial (and this one is really nice written and clear) but if I can't get rid of this issue with python-imaging and 3.1.2.0ubuntu1.1, I'll install linuxCNC liveCD. Thanks to everybody for your advices and info.
More
01 Nov 2017 07:49 #101103 by ozzyrob
Have you tried installing python-imaging via synaptic (under package manager in the "start menu"). 3.1.2.0ubuntu1.1 is the version. I'm pretty sure that should have been installed via the Dependencies on page 1 of this thread.
More
01 Nov 2017 08:16 #101104 by Thierry
Python-imaging is actually installed, the problem comes with python-imaging-tk (and python-imaging2.7-tk- that I can't install.
Typing sudo apt-get install python-imaging-tk returns
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-imaging-tk : Dépend: python-imaging (= 1.1.7-4) mais 3.1.2-0ubuntu1.1 devra être installé
E: Unable to correct the problem, you have held broken packages*.

* My linux is in french so I guess this is what to read for "des paquets défectueux sont en mode « garder en l'état »."

Synoptics doesn't show any broken packets..
More
01 Nov 2017 08:44 #101106 by ozzyrob
Try

sudo apt-get install python-pil.imagetk

I think this is the package you are missing.....I just checked my machine
The following user(s) said Thank You: cncnoob1979
More
01 Nov 2017 08:57 #101107 by Thierry
Successfully done.
Should try to install python-imaging-tk now ?
More
01 Nov 2017 09:19 - 01 Nov 2017 09:19 #101108 by ozzyrob
According to Ubuntu python-pil.imagetk provides python-imaging-tk, as per packages.ubuntu.com/xenial/python-imaging-tk so you should good to go
Last edit: 01 Nov 2017 09:19 by ozzyrob.
The following user(s) said Thank You: Thierry
Time to create page: 0.120 seconds
Powered by Kunena Forum