Complete HOW-TO Linux Mint 18.1 32/64 RTAI or PREEMPT with RIP install or deb

More
16 Mar 2017 03:49 #89716 by fjr122
I'm sorry, but I'm still having issues..

I did as you instructed:
In the last step I get
The following packages have unmet dependencies:
 linux-headers-3.4-9-rtai-686-pae:i386 : Depends: gcc-4.6:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then I tried the following, because I don't really know the syntax.. anyways
linuxcnc@linuxcnc ~ $ sudo apt-get install gcc-4.6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gcc-4.6:i386 : Depends: binutils:i386 (>= 2.21.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 03:54 #89718 by cncnoob1979
You added the repo listed above first?

Then
sudo apt-get update prior to trying that step?

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 03:57 #89719 by fjr122
Yes, as instructed.. and gcc 4.6 installed successfully ..

I ran this command after typing the above post..
sudo apt-get install gcc-4.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gcc-4.6 is already the newest version (4.6.3-1ubuntu5).
0 upgraded, 0 newly installed, 0 to remove and 547 not upgraded.

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 03:57 - 16 Mar 2017 04:15 #89720 by cncnoob1979
Last edit: 16 Mar 2017 04:15 by cncnoob1979.

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 04:01 #89721 by fjr122
Running another apt-get update, should be able to do that in 15min or so..

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 04:07 - 16 Mar 2017 04:16 #89722 by cncnoob1979
Seems you might have a corruption issue with your wifi dongle. Are you able to connect hardwire for testing?

Can you take a picture of your repos listed in the package manager?

If you have the time update to the latest software via apt

Disable the repo you enabled earlier to prevent any possibilities of an issue. You can do that by unchecking the repo listed in the package manager.


Then run:
sudo apt-get dist-upgrade

You have 500+ packages that need updated.
Last edit: 16 Mar 2017 04:16 by cncnoob1979.

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 04:14 #89724 by cncnoob1979
Disregard the binutils above. gcc 4.6 is installed.

Try the kernel install again. It should install this time. (I would still update wether successful or not).

I didn't notice the :386 at the end of the apt command previously.

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 04:28 #89725 by fjr122
Running the upgrade now: ... possibly should have been the first thing I did.. this should take a while..
~ $ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  autoconf automake autopoint dh-autoreconf gir1.2-appindicator3-0.1 gist
  libgdm1 libruby2.3 libtag1v5:i386 libtool rake ruby ruby-did-you-mean
  ruby-json ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit
  ruby2.3 rubygems-integration xapps-common
The following packages will be upgraded:
  accountsservice apt apt-transport-https apt-utils apt-xapian-index
  archdetect-deb base-files bash-completion bind9-host brasero brasero-cdrkit
  brasero-common brltty bsdutils casper cinnamon cinnamon-common
  command-not-found command-not-found-data console-setup console-setup-linux
  cpp-5 cups-browsed cups-filters cups-filters-core-drivers curl dbus dbus-x11
  debhelper desktop-file-utils dh-python distro-info-data dkms dmidecode
  dnsmasq-base dnsutils dosfstools dpkg dpkg-dev ecryptfs-utils file-roller
  firefox firefox-locale-en fontconfig fontconfig-config fonts-noto-cjk
  fonts-opensymbol fuse fwupd g++-5 gcc-5 gcc-5-base gcc-5-base:i386 gdb
  ghostscript ghostscript-x gimp gimp-data gir1.2-accountsservice-1.0
  gir1.2-dbusmenu-glib-0.4 gir1.2-gdkpixbuf-2.0 gir1.2-gmenu-3.0
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0
  gir1.2-javascriptcoregtk-3.0 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0
  gir1.2-packagekitglib-1.0 gir1.2-upowerglib-1.0 gir1.2-webkit-3.0
  gir1.2-webkit2-3.0 glib-networking glib-networking:i386
  glib-networking-common glib-networking-services gnome-calculator
  gnome-font-viewer gnome-menus gnome-panel gnome-panel-data gnome-session-bin
  gnome-settings-daemon gnome-settings-daemon-schemas gnome-system-monitor
  gnupg gpgv graphviz grep grub-common grub-pc grub-pc-bin grub2-common
  gstreamer0.10-gconf gstreamer0.10-plugins-good
  gstreamer0.10-plugins-good:i386 gstreamer0.10-pulseaudio gstreamer1.0-alsa
  gstreamer1.0-plugins-base gstreamer1.0-plugins-base-apps
  gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gstreamer1.0-tools
  gstreamer1.0-x gtk2-engines-murrine gtk2-engines-murrine:i386 gufw gvfs
  gvfs:i386 gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-fuse
  gvfs-libs gvfs-libs:i386 ifupdown im-config imagemagick imagemagick-6.q16
  imagemagick-common init init-system-helpers initramfs-tools
  initramfs-tools-bin initramfs-tools-core isc-dhcp-client isc-dhcp-common kbd
  keyboard-configuration klibc-utils kpartx kpartx-boot krb5-locales
  language-pack-en language-pack-en-base language-pack-gnome-en
  language-pack-gnome-en-base less libaccountsservice0 libapparmor1
  libappindicator0.1-cil libappindicator1 libappindicator3-1
  libappstream-glib8 libapt-inst2.0 libapt-pkg5.0 libarchive13 libasan2
  libatomic1 libbind9-140 libblkid1 libboost-date-time1.58.0
  libboost-filesystem1.58.0 libboost-iostreams1.58.0 libboost-python1.58-dev
  libboost-python1.58.0 libboost-regex1.58.0 libboost-system1.58.0
  libboost1.58-dev libbrasero-media3-1 libbrlapi0.6 libc-bin libc-dev-bin
  libc6 libc6:i386 libc6-dbg libc6-dev libcaja-extension1 libcc1-0 libcdt5
  libcgraph6 libcilkrts5 libcupsfilters1 libcupsfilters1:i386 libcurl3-gnutls
  libdbus-1-3 libdbus-1-3:i386 libdbusmenu-glib4 libdbusmenu-gtk3-4
  libdbusmenu-gtk4 libdebian-installer4 libdfu1 libdns-export162 libdns162
  libdpkg-perl libdrm-amdgpu1 libdrm-amdgpu1:i386 libdrm-dev libdrm-intel1
  libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1
  libdrm-radeon1:i386 libdrm2 libdrm2:i386 libecryptfs1 libegl1-mesa
  libegl1-mesa-drivers libevent-2.0-5 libexiv2-14 libexpat1 libexpat1:i386
  libexpat1-dev libfdisk1 libfontconfig1 libfontconfig1:i386
  libfontconfig1-dev libfontembed1 libfuse2 libfwupd1 libgail-3-0 libgbm1
  libgc1c2 libgcc-5-dev libgcrypt20 libgcrypt20:i386 libgd3 libgd3:i386
  libgdk-pixbuf2.0-0:i386 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgdk-pixbuf2.0-dev libgfortran3 libgif7 libgimp2.0 libgl1-mesa-dev
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libgl1-mesa-glx
  libglapi-mesa libglapi-mesa:i386 libgles1-mesa libgles2-mesa
  libglib2.0-0:i386 libglib2.0-0 libglib2.0-bin libglib2.0-data libglib2.0-dev
  libgnome-menu-3-0 libgnutls-openssl27 libgnutls30 libgnutls30:i386 libgomp1
  libgs9 libgs9-common libgssapi-krb5-2 libgssapi-krb5-2:i386
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-base1.0-0:i386
  libgstreamer-plugins-good1.0-0 libgstreamer1.0-0 libgstreamer1.0-0:i386
  libgtk-3-0 libgtk-3-bin libgtk-3-common libgvc6 libgvpr2 libgweather-3-6
  libgweather-common libharfbuzz-dev libharfbuzz-gobject0 libharfbuzz-icu0
  libharfbuzz0b libharfbuzz0b:i386 libhogweed4 libhogweed4:i386 libicu55
  libicu55:i386 libidn11 libidn11:i386 libimobiledevice-utils
  libimobiledevice6 libisc-export160 libisc160 libisccc140 libisccfg140
  libitm1 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0
  libjavascriptcoregtk-4.0-18 libjpeg-progs libjpeg9 libk5crypto3
  libk5crypto3:i386 libklibc libkrb5-3 libkrb5-3:i386 libkrb5support0
  libkrb5support0:i386 libksba8 libldap-2.4-2 libllvm3.8 libllvm3.8:i386
  liblsan0 liblwres141 libmagick++-6.q16-5v5 libmagickcore-6.q16-2
  libmagickwand-6.q16-2 libmetacity-private3a libmount1 libmpx0
  libnautilus-extension1a libndp0 libnettle6 libnettle6:i386 libnm-glib-vpn1
  libnm-glib4 libnm-gtk-common libnm-gtk0 libnm-util2 libnm0 libnma-common
  libnma0 libnspr4 libnspr4:i386 libnss3 libnss3:i386 libnss3-1d libnss3-nssdb
  libnux-4.0-common libopenobex2 libp11-kit0 libp11-kit0:i386
  libpackagekit-glib2-16 libpam-systemd libpanel-applet0 libpathplan4
  libpcsclite1 libplymouth4 libpoppler-glib8 libpoppler58 libprocps4
  libpulse-mainloop-glib0 libpulse-mainloop-glib0:i386 libpulse0
  libpulse0:i386 libpulsedsp libpulsedsp:i386 libpurple-bin libpurple0
  libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib
  libpython3.5 libpython3.5-minimal libpython3.5-stdlib libqt5core5a
  libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5
  libqt5sql5 libqt5sql5-sqlite libqt5widgets5 libqt5xml5 libquadmath0
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
  libreoffice-base-drivers libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-java-common
  libreoffice-math libreoffice-ogltrans libreoffice-pdfimport
  libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-writer
  libservlet3.1-java libsmartcols1 libsmbclient libssl-dev libssl1.0.0
  libssl1.0.0:i386 libstdc++-5-dev libstdc++6 libstdc++6:i386 libsystemd0
  libsystemd0:i386 libtasn1-6 libtasn1-6:i386 libtevent0 libtiff5
  libtiff5:i386 libtsan0 libubsan0 libudev-dev libudev1 libudev1:i386
  libunity-protocol-private0 libunity-scopes-json-def-desktop libunity9
  libupower-glib3 libusbmuxd4 libuuid1 libuuid1:i386 libwayland-egl1-mesa
  libwbclient0 libwebkit2gtk-3.0-25 libwebkit2gtk-4.0-37 libwebkitgtk-1.0-0
  libwebkitgtk-1.0-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
  libwnck-common libwnck22 libxatracker2 libxml2 libxml2:i386 libxml2-utils
  libxpm-dev libxpm4 libxpm4:i386 linux-firmware linux-libc-dev locales
  lsb-base lsb-release lshw mesa-common-dev metacity metacity-common
  mint-artwork-common mint-meta-cinnamon mint-meta-core mint-mirrors
  mint-themes-gtk3 mint-upgrade-info mint-x-icons mint-y-theme mintbackup
  mintdrivers mintinstall mintsources mintsystem mintupdate mintupload
  mintwelcome mount mtools mtr-tiny multiarch-support nano nautilus-data
  network-manager network-manager-gnome network-manager-openvpn
  network-manager-openvpn-gnome ntfs-3g ntp ntpdate nux-tools
  nvidia-prime-applet openjdk-8-jre openjdk-8-jre-headless openssh-client
  openssl os-prober p11-kit p11-kit-modules pidgin pidgin-data pix pix-data
  plymouth plymouth-label plymouth-theme-ubuntu-text poppler-utils
  printer-driver-brlaser procps pulseaudio pulseaudio-module-bluetooth
  pulseaudio-module-x11 pulseaudio-utils python-crypto python-cryptography
  python-imaging python-libxml2 python-pil python-pil.imagetk python-samba
  python2.7 python2.7-dev python2.7-minimal python3-brlapi
  python3-commandnotfound python3-crypto python3-cryptography python3-pil
  python3-uno python3-urllib3 python3.5 python3.5-minimal resolvconf
  samba-common samba-common-bin samba-libs shared-mime-info smbclient sni-qt
  ssh-askpass-gnome sudo systemd systemd-sysv tar tcpdump thermald thunderbird
  thunderbird-gnome-support tzdata ubuntu-drivers-common
  ubuntu-system-adjustments udev unattended-upgrades uno-libs3 upower upstart
  ure util-linux uuid-runtime vim-common vim-tiny vino virtualbox-guest-dkms
  virtualbox-guest-utils virtualbox-guest-x11 wget xdg-utils xinit
  xserver-common xserver-xorg-core xserver-xorg-video-amdgpu
  xserver-xorg-video-intel xviewer
546 upgraded, 21 newly installed, 0 to remove and 0 not upgraded.
Need to get 652 MB of archives.
After this operation, 131 MB of additional disk space will be used.
Do you want to continue? [Y/n] y

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 05:24 #89728 by fjr122
Ok, I did the dist-upgrade..

The problem still persists..

Please Log in or Create an account to join the conversation.

More
16 Mar 2017 10:28 #89736 by rodw
When I go back and review your original post about this error
linux-headers-3.4-9-rtai-686-pae:i386 : Depends: gcc-4.6:i386 but it is not installable

It seems to me you are trying to install a 64 bit 686 library on a 32 bit 386 system but I am really a Linux noob so could be way off.

I think if you do have a 386 system, you would be better sticking with the standard Wheezy ISO. It implies you have older hardware that is most likely to be supported by the older OS. I found on a 32 bit system that when I moved from Wheezy to Jessie, to install the PREEMPTIVE kernel, the latency rendered the system unusable. I suspect that Mint may put some stress on old hardware so you may end up retreating away from Mint anyway. To solve my problems, I upgraded to 64 bit hardware but then had ongoing issues with Jessie due to lack of driver support. Based on all sorts of advice, I ended up with broken dependencies and realised I had to reinstall the OS. The switch to Mint solved this totally. So don't give up yet, others have also had a rocky journey to get a working system.

Please Log in or Create an account to join the conversation.

Time to create page: 0.118 seconds
Powered by Kunena Forum