Inconsistent Error Messages

More
23 Feb 2021 16:44 #199853 by snowgoer540
I am having some issues with inconsistent error message popups (the style of the welcome screen) on my machine.

At first I thought it was an issue related to having the welcome screen disabled. So I enabled it and they worked again for a few errors (coincidence I think). Now I see them sporadically again.

I should note that I see the errors reliably on the bottom left of the QtPlasmaC screen, as well as in the terminal. The problem with the ones on the bottom left is they go away if you move your mouse. Problem with the terminal is not everyone launches LinuxCNC that way.

I've heard others see the popups reliably and in full disclosure I am running Mint 19.2, so it's possible that it's a Mint thing. But I know a lot of people on here use Mint (even know it's not the technically supported distro).

Just thought I would ask, happy to provide any extra info, as always.

Please Log in or Create an account to join the conversation.

More
23 Feb 2021 17:02 #199858 by tommylight
QtVPC v0.9.41, LinuxCNC v2.9.0 build 3566, QtPlasmaC sim "L" size, no errors besides the first one on Linux Mint 19.3.
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

More
23 Feb 2021 18:35 #199872 by snowgoer540

QtVPC v0.9.41, LinuxCNC v2.9.0 build 3566, QtPlasmaC sim "L" size, no errors besides the first one on Linux Mint 19.3.


Glad to know I’m not the only one. Not glad to know it might be a minty thing.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
23 Feb 2021 21:10 #199890 by tommylight
Hmmm you are ! :)
The only error i get is the first start after update regarding material something, no more errors of any kind on this PC.
Well, my bad, that is a warning, not an error, sorry for the confusion ... and sorry to leave you alone in the dark ... and in the cold ! :)

Please Log in or Create an account to join the conversation.

More
23 Feb 2021 22:43 #199897 by snowgoer540

Hmmm you are ! :)
The only error i get is the first start after update regarding material something, no more errors of any kind on this PC.
Well, my bad, that is a warning, not an error, sorry for the confusion ... and sorry to leave you alone in the dark ... and in the cold ! :)


I’m confused. I’m still not sure if you’re saying there’s no errors on your system or you aren’t seeing any pop ups? I think you are saying other than the welcome message you don’t see any errors (better known as pop ups maybe).

Could you try something that intentionally causes an error and see if you get a pop up? Trip a limit, breakaway, etc? Try it a few times see if they keep coming up?

Please Log in or Create an account to join the conversation.

More
24 Feb 2021 00:19 #199902 by tommylight

QtVPC v0.9.41, LinuxCNC v2.9.0 build 3566, QtPlasmaC sim "L" size, no errors besides the first one on Linux Mint 19.3.

No errors or popups even when tripping float/ohmic/breakaway during simulation run.
To cold and to dark to go out and check on a machine, 1:17AM here, but will try to test that tomorrow, if i do not forget, so feel free to remind me .... :)

Please Log in or Create an account to join the conversation.

More
24 Feb 2021 01:51 #199914 by snowgoer540

QtVPC v0.9.41, LinuxCNC v2.9.0 build 3566, QtPlasmaC sim "L" size, no errors besides the first one on Linux Mint 19.3.

No errors or popups even when tripping float/ohmic/breakaway during simulation run.
To cold and to dark to go out and check on a machine, 1:17AM here, but will try to test that tomorrow, if i do not forget, so feel free to remind me .... :)


Sounds like we are in the same boat after all :)

I should note I see this in SIM and on the real machine. Both Mint 19.2

Please Log in or Create an account to join the conversation.

More
24 Feb 2021 01:51 #199915 by tommylight
Did a test on one of the laptops with RT kernel, material error at start, breakaway and float errors when triggered during run, all with the latest master and all popups.
Plenty of warnings on terminal though, and neither of them resumes after the induced error, it just sits there doing nothing after pressing "resume", have to disable/enable and start over.
This is still on sim, newest build, and same thing with the bottom left side with the errors disappearing when moving the mouse over buttons, the popups remain till cleared.
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
24 Feb 2021 02:55 #199922 by cmorley
Replied by cmorley on topic Inconsistent Error Messages
Can you try another qyvcp sample screen to see if it's screen code related?

Please Log in or Create an account to join the conversation.

More
24 Feb 2021 08:47 #199941 by phillc54
FWIW my Debian Buster sims and machine and my MX Linux 19.3 sims and machine all show the error popups correctly.

I thought I posted a reply earlier but it doesn't seem to be there, I don't know where I am...

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.246 seconds
Powered by Kunena Forum