LinuxCNC on Linux Mint 19

More
15 Apr 2019 04:14 - 15 Apr 2019 04:18 #130884 by InMyDarkestHour

jackotool wrote: what is u space? - I only followed the instructions ... if upsace was included in the instructions, then I would have configured uspace?


Meh
Last edit: 15 Apr 2019 04:18 by InMyDarkestHour.

Please Log in or Create an account to join the conversation.

More
15 Apr 2019 04:39 #130886 by jackotool
Replied by jackotool on topic LinuxCNC on Linux Mint 19
debian/configure uspace

I did this if this is what you mean

Please Log in or Create an account to join the conversation.

More
15 Apr 2019 06:00 #130887 by InMyDarkestHour
what kernel are you running ?

Please Log in or Create an account to join the conversation.

More
15 Apr 2019 06:26 #130889 by pl7i92
Replied by pl7i92 on topic LinuxCNC on Linux Mint 19
can you post the output of
uname -a
please

Please Log in or Create an account to join the conversation.

More
17 Apr 2019 09:58 #131049 by BigJohnT
Replied by BigJohnT on topic LinuxCNC on Linux Mint 19

jackotool wrote: Hello,
Thanks for the instructions - I have followed carefully -but when i get to "dpkg-checkbuilddeps"
I get error message "dpkg-checkbuilddeps: error: Unmet build dependencies: rtai-modules-3.4-9-rtai-686-pae intltool" How do I add this dependency? I thought it was already there?

gnipsel.com/linuxcnc/uspace/linuxmint19-emc.html

Any help appreciated ...

Many thanks,

Jack


Did you do step 1 first? gnipsel.com/linuxcnc/uspace/linuxmint19-rt.html

JT

Please Log in or Create an account to join the conversation.

More
25 Apr 2019 19:54 #131879 by paulctan
Replied by paulctan on topic LinuxCNC on Linux Mint 19
I can confirm that as of today, 25-Apr-2019, the instructions provided by BigJohnT worked perfectly. The only change I made was to run 'make -j4' instead of just 'make'. Speeds up the kernel build considerably.

Great Job BigJohnT!

I can also confirm that attempting to do the same instructions using just Ubuntu 18.04 LTS fails, so Mint is adding some other packages that are needed by LinuxCNC.

One quick question though: Is there any advantage to building the latest Preempt_RT kernel instead of the .1 version? I think the latest build with _RT is .31.

Please Log in or Create an account to join the conversation.

More
26 Apr 2019 00:11 #131908 by BigJohnT
Replied by BigJohnT on topic LinuxCNC on Linux Mint 19
I assume as they fix things it's better to use the latest version but you know what assume means lol.

JT

Please Log in or Create an account to join the conversation.

More
26 Apr 2019 15:19 #131975 by tommylight
Assumption = the mother of all f###ups ! :)
Very true.

Please Log in or Create an account to join the conversation.

More
29 Apr 2019 23:51 #132321 by JD1
Replied by JD1 on topic LinuxCNC on Linux Mint 19
Thank you for the instructions.

I currently have Linux Mint 19.1 installed – and want to install linuxcnc.

I followed carefully but my computer fails to restart after finishing step 1. gnipsel.com/linuxcnc/uspace/linuxmint19-rt.html

System Info
Operating System Linux Mint 19.1 Cinnamon
Cinnamon Version 4.0.10
Linux Kernel 4.15.0-48-generic
Processor Intel Core i5-2500 CPU @ 3.30GHz x 4
Memory 13.6 GiB
Hard Drive 76.4 GB
Graphics Card Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller


Any help is appreciated

Please Log in or Create an account to join the conversation.

More
30 Apr 2019 05:12 #132325 by InMyDarkestHour
You will have to explain what actually happens, "fails to restart" is pretty vague.

Can you still boot using the old kernel....it may be under the Advanced options menu item.

Please Log in or Create an account to join the conversation.

Time to create page: 0.103 seconds
Powered by Kunena Forum