Custom Mint-19.2 with Linuxcnc

More
24 Apr 2020 12:05 #165380 by tommylight

Just in case anyone has a sudden urge :
tomberisha.com/


A man after my own heart. Its pretty obsolete now but I registered rodwebster.com.au and spent some time getting to #1 on Google.

I am quite the opposite, i do not want to be found! Till about 4 or 5 years you could find nothing about me on the net ! Nothing!
Quite a feat since i am on the net since the time of BBS ! Hell, google knows nothing about me now, i checked last year.
But if you search for tommylight, there is plenty, for the last few years.

Please Log in or Create an account to join the conversation.

More
24 Apr 2020 14:50 #165401 by getyers
can you pm or email at This email address is being protected from spambots. You need JavaScript enabled to view it. when linuxcnc and linux mint are together again because i love linux mint. thanks getyers

Please Log in or Create an account to join the conversation.

More
24 Apr 2020 15:10 #165404 by BeagleBrainz
Keep an eye on this thread, when it's ready I'll make an announcement

Cheers
Rob
The following user(s) said Thank You: Clive S, tivoi, getyers, berntmartin

Please Log in or Create an account to join the conversation.

More
30 Apr 2020 23:13 #166261 by BeagleBrainz
See here for new ISO & repo for updatng Linuxcnc packages
forum.linuxcnc.org/9-installing-linuxcnc...aver-mint-iso#165631
The following user(s) said Thank You: phillc54, tommylight, Clive S

Please Log in or Create an account to join the conversation.

More
17 May 2021 12:15 #209220 by Arthur_L
Hi,
Do you install linuxcnc with RTAI? I use kernel 4.14.111 and rtai-5.2 ,but when i
compile linuxcnc-dev, i get field.Must fix rtati?

Please Log in or Create an account to join the conversation.

More
17 May 2021 12:22 #209221 by BeagleBrainz
The following user(s) said Thank You: Arthur_L

Please Log in or Create an account to join the conversation.

More
18 May 2021 11:29 #209340 by Arthur_L
I want to compile and install linuxcnc from the source code. First, I want to compile and install the linux kernel and rtai from the source code. The linux kernel version I compiled is 4.14.111 and the rtai version is 5.2, but I get an error when compiling linuxcncs. The RTAI official website release version matches the Linux kernel version. My question is, does rtai need to be modified, in other words, linuxcnc needs a dedicated RTAI?

Please Log in or Create an account to join the conversation.

More
18 May 2021 14:04 #209353 by BeagleBrainz
If you search the forum for rtai release there is a thread that has a link to a git hub repo for the rtai source.

Be warned there are some issues with the rtai kernel.

In all honesty addressing your issues in a new topic would be a better idea. Andy or Bari should hopefully chime in.
Another idea would be to start a thread on the emc users mailing list. Links to this can be found on the Linuxcnc homepage.
The following user(s) said Thank You: Arthur_L

Please Log in or Create an account to join the conversation.

More
18 May 2021 17:33 #209368 by Bari
Replied by Bari on topic Custom Mint-19.2 with Linuxcnc
github.com/NTULINUX/RTAI we don't have the time to support you if you choose to build from scratch.

The easiest way is to download and use the packages linuxcnc.org/downloads/
The following user(s) said Thank You: BeagleBrainz, Arthur_L

Please Log in or Create an account to join the conversation.

More
19 May 2021 01:15 #209431 by Arthur_L
Thanks for the Suggest. I creat a new topic.

Please Log in or Create an account to join the conversation.

Time to create page: 0.243 seconds
Powered by Kunena Forum