Help with homing on dual axis PlasmaC

More
25 Jul 2020 13:03 #175737 by phillc54
Are you sure the machine is set to 20:1?

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 13:12 - 25 Jul 2020 14:31 #175738 by Clive S

Are you sure the machine is set to 20:1?


Yes I have a pic of the switches they are all down.

THC active does not light up nor does the thc up/down light

Cutting a circle and a line from extras is what we are using to cut. I take that does use THC

Also I have changed the Scale 00753917 offset to be 3637.5 which is different from the pics

Have also noticed from afar that the THC velocity lock light comes on when cutting
Last edit: 25 Jul 2020 14:31 by Clive S.

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 13:23 #175741 by snowgoer540
Scale and offsets look good (figured, but good to check).

You're sure you have it set in unipolar, correct?

Also all of these in your <machine_name_connections>.hal:
setp  hm2_7i96.0.encoder.00.scale -1
setp  hm2_7i96.0.encoder.00.filter 1
setp  hm2_7i96.0.encoder.00.counter-mode 1
hm2_7i96.0.encoder.00.velocity

Figuring you do, but again, covering the simple stuff.

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 13:42 - 25 Jul 2020 13:50 #175743 by Clive S

Scale and offsets look good (figured, but good to check).

You're sure you have it set in unipolar, correct?

Also all of these in your <machine_name_connections>.hal:
setp  hm2_7i96.0.encoder.00.scale -1
setp  hm2_7i96.0.encoder.00.filter 1
setp  hm2_7i96.0.encoder.00.counter-mode 1
hm2_7i96.0.encoder.00.velocity

Figuring you do, but again, covering the simple stuff.


Yes top 3 in the machine.hal and the other in connections.hal

Have also noticed from afar that the THC velocity lock light comes on when cutting

Edit Yes unipolar
Last edit: 25 Jul 2020 13:50 by Clive S.

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 18:37 #175772 by tommylight
Is it possible to upgrade Linuxcnc as you are on 12n version of PlasmaC, the latest is 142, if i remember correctly.
Had the same issue on version 97 a while back, after upgrade everything worked.
The following user(s) said Thank You: Clive S

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 18:49 #175775 by Clive S

Is it possible to upgrade Linuxcnc as you are on 12n version of PlasmaC, the latest is 142, if i remember correctly.
Had the same issue on version 97 a while back, after upgrade everything worked.


I think he did a sudo update and sudo dist-upgrade yesterday. So that should have done it I believe.

I did not notice the version number in the Pics.

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 19:00 - 25 Jul 2020 19:01 #175777 by tommylight
Today it is at 0.144
BTW, for the last 4 or 5 days LinuxCNC upgrades were not working.
Last edit: 25 Jul 2020 19:01 by tommylight. Reason: More info

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 19:03 - 25 Jul 2020 19:04 #175778 by Clive S

Today it is at 0.144


Yes I have just checked 0.145 now He did do the above yesterday just checked. I have told him to do it again via the configurator upgrade method and then re do the sudo update stuff again
Last edit: 25 Jul 2020 19:04 by Clive S.

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 21:33 #175793 by rodw
What THCAD?
What is his THCAD scaling resistor value?
You need to work thru this progressively. But if you have a negative 0 volt reading its a software issue becasue 0 volts on the THCAD is a positive number (3637.5)

Use halshow to check that the encoder count is near 3637.5 when not cutting. Does that look right?
Then apply something close to the full scale reading eg 9 volt, 5 volt and see what the count is then. Do the maths and see if the encoder is correct.

Only after you confirm the encoder is seeing the correct reading would I bother about the scaling.

Its always best to start at the beginning and work through each step when troubleshooting.
The following user(s) said Thank You: Clive S

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 21:34 #175794 by tommylight
No need to use configurator, till now twice it was done automagically.
Thank you Phill ! :)

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.178 seconds
Powered by Kunena Forum