7i96 Configuration Tool

More
05 Nov 2018 22:45 #120051 by BigJohnT
Replied by BigJohnT on topic 7i96 Configuration Tool
Two reasons, simplicity in configuration is the overwhelming drive for me to write it. IMHO it's easier for a NewBee to use a tool designed for the card and not have so many selections to try and understand.

I didn't write pncconf so I don't know anything about it. I tried to look at it once but you needed something special to open it (I forget it's been a long time) so I quit. Even I get confused trying to build a configuration with pncconf...

JT
The following user(s) said Thank You: Ewok2

Please Log in or Create an account to join the conversation.

More
11 Dec 2018 08:38 #122185 by pl7i92
Replied by pl7i92 on topic 7i96 Configuration Tool
Is someone doing simultaneity to 7i92 ?

Please Log in or Create an account to join the conversation.

More
13 Dec 2018 07:21 #122354 by tommylight
Replied by tommylight on topic 7i96 Configuration Tool
7i92 is technically the same as 5i25 or 6i25, the only difference is it uses ethernet to communicate with the computer.
Pncconfig has provisions for 5i25, so you make a 5i25 config, open the hal file with gedit or pluma or mousepad and replace every 5i25 to 7i92.
That does not apply to firmware, do not use 5i25 firmware on a 7i92.

Please Log in or Create an account to join the conversation.

More
18 Dec 2018 03:05 #122545 by tcalow
Replied by tcalow on topic 7i96 Configuration Tool
Hello BigJohnT,
I have tried out your configuration tool on a fresh install of the Debian Stretch, RT-PREEMPT live CD. I get an error Pin 'joint.0.amp-enable-out' does not exist. I am new to LinuxCNC but I think that this pin should be created by motmod. Im not sure why it's not there. If I comment out that line I get an error that pin joint.0.motor-pos-cmd does not exist. I have attached my hal, ini and the Error file. Any insight would be greatly appreciated.

Thanks,
Tyler
Attachments:

Please Log in or Create an account to join the conversation.

More
18 Dec 2018 14:16 #122572 by PCW
Replied by PCW on topic 7i96 Configuration Tool
It looks like the configuration tool is written for LinuxCNC 2.8, not 2.7 so will have many
"axis" -- "joint" name issues if you try to run a config on a LinuxCNC 2.7 system
The following user(s) said Thank You: BigJohnT, Ewok2

Please Log in or Create an account to join the conversation.

More
22 Dec 2018 11:50 #122747 by Ewok2
Replied by Ewok2 on topic 7i96 Configuration Tool
Wonderful tools !!!
Thanks

Just 2 comments :
- In the Axis tab / Joint in the joint information, I get a distance to accelerate to max speed in inches despite the fact I select the Metric system in the First Tab :-)
- In the PC Tab, when I select the Read tMax I did not get a value in return ?

Please Log in or Create an account to join the conversation.

More
23 Dec 2018 11:52 #122776 by Ewok2
Replied by Ewok2 on topic 7i96 Configuration Tool
Hello BigJohnT
I had a configuration working.
I open the ini file with your tools and do the minimum of modification for the check to be Ok (Pass in Metric, put the scale to 1 and assign Joint to axis)
But when I execute LinuxCnc after building with your tool I get 2 Error messages :
- Unexpected realtime delay on task 0 with period 100000. Run the Latency Test and resolve before continuing.
- hm2/hm2-7i96.0 : error finishing read! iter=6

Any idea of the reason ?

Please Log in or Create an account to join the conversation.

More
23 Dec 2018 12:57 #122777 by PCW
Replied by PCW on topic 7i96 Configuration Tool
Yes, you have the servo thread period way too short
Typical servo thread period is 1 ms (1000000 ns)

Please Log in or Create an account to join the conversation.

More
23 Dec 2018 14:06 #122778 by Ewok2
Replied by Ewok2 on topic 7i96 Configuration Tool
Yes you are right with 1000000 it is better.
It seem's that the tools 7i96 put it again to 100000 even if previous ini file had 1000000.

After this correction the linuxcnc open without warning, but when trying to move one axis with the manual control, I get a "joint 0 following error, emc/task/taskintf.cc 946: Error on the joint 0, command number 92"

Any idee of the pb ?

Please Log in or Create an account to join the conversation.

More
23 Dec 2018 14:18 #122780 by PCW
Replied by PCW on topic 7i96 Configuration Tool
Can you post the generated hal and ini files?

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.135 seconds
Powered by Kunena Forum