7i96 Configuration Tool

More
30 May 2019 22:01 #135428 by BigJohnT
Replied by BigJohnT on topic 7i96 Configuration Tool
If your using debian 9 you need to add the .xsessionrc file so your path is known. If you did that and did not log out or reboot it will not work until you do.

JT

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 15:53 #136070 by Project_Hopeless
This is probably more a Linux question but related to the tool.

I have the 7i96 Tool running and communicating with my 7i96 card. The problem is I can't seem to save my configuration. I try Save As and in the terminal I give it a name, enter, and nothing happens. Simply using Save and nothing happens. I checked the \config directory and no file. The path field is grey'd out, not sure if you can edit this.

Am I running into some permission level issue? I'm a Linux newbee also.

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 17:45 #136076 by PCW
Replied by PCW on topic 7i96 Configuration Tool
I'm not sure where the configuration tool writes its output, have you tried running it in
~/linuxcnc/configs/
?

(just in case it writes its output to the current directory)

Please Log in or Create an account to join the conversation.

More
06 Jun 2019 20:36 - 06 Jun 2019 20:41 #136088 by BigJohnT
Replied by BigJohnT on topic 7i96 Configuration Tool
Sorry I should have removed the non functioning menu items. You need to press Build Configuration button to check the configuration for errors then build and save the configuration to linuxcnc/configs/nameofconfig. You can also press the Check Configuration button at any time and see if you have any missing entries.

JT
Last edit: 06 Jun 2019 20:41 by BigJohnT.
The following user(s) said Thank You: Project_Hopeless

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 00:35 #136142 by Project_Hopeless
JT,

The tool and files it creates are for v2.8 only correct ?

Please Log in or Create an account to join the conversation.

More
07 Jun 2019 10:44 #136192 by BigJohnT
Replied by BigJohnT on topic 7i96 Configuration Tool
That is correct, the 7i96 only works on 2.8

JT

Please Log in or Create an account to join the conversation.

More
09 Jun 2019 14:55 #136377 by persei8
Replied by persei8 on topic 7i96 Configuration Tool
I installed 7i96 according to instructions at github. Using LINUXCNC - 2.8.0-pre1-4740-g60416609a
Successfully installed 7i96-0.1.0
Running 7i96 shows it is version 0.0.2
The github documentation shows screens of version 1.0
So what version is it really and how do I get the latest because the documentation shows screen items that do not exist on my installed version. Thanks.

Please Log in or Create an account to join the conversation.

More
09 Jun 2019 15:50 #136384 by Project_Hopeless
In StepConf there is a "tandum" label. For the 7i96 tool how do you setup a two motor tandem axis? Do you just make two X axis? Does the order matter?

Please Log in or Create an account to join the conversation.

More
09 Jun 2019 19:41 #136394 by BigJohnT
Replied by BigJohnT on topic 7i96 Configuration Tool

persei8 wrote: I installed 7i96 according to instructions at github. Using LINUXCNC - 2.8.0-pre1-4740-g60416609a
Successfully installed 7i96-0.1.0
Running 7i96 shows it is version 0.0.2
The github documentation shows screens of version 1.0
So what version is it really and how do I get the latest because the documentation shows screen items that do not exist on my installed version. Thanks.


That is because the programmer (me) failed to keep both the setup.py and the 7i96.py versions in sync, it has been fixed and pushed.

The screen shots will always be behind the configuration tool because I forget to update them, which screen is different?

JT

Please Log in or Create an account to join the conversation.

More
09 Jun 2019 19:45 #136396 by BigJohnT
Replied by BigJohnT on topic 7i96 Configuration Tool

Project_Hopeless wrote: In StepConf there is a "tandum" label. For the 7i96 tool how do you setup a two motor tandem axis? Do you just make two X axis? Does the order matter?


The configuration tool knows to put multiple joints with the same axis as a gantry. I've added that information to the help page for axes.

The only order that matters is you start with joint 0 and don't skip a joint, the axis letter assignment does not matter.

JT

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.117 seconds
Powered by Kunena Forum