Another plasma component...

More
09 May 2019 17:17 #133256 by JTknives
When I try and jog any of the axis I get a “joint # fallowing error” where the # corasponds to x=0 y=1 and z=2. Also the control trips out and has to be turned back on.

Please Log in or Create an account to join the conversation.

More
09 May 2019 19:30 #133274 by JTknives
Weird thing is if I load imperial_plasmac all the axis run fine but if I run the mymachine from the configuration selector it runs all axis fine.

Please Log in or Create an account to join the conversation.

More
09 May 2019 20:41 #133287 by rodw
Replied by rodw on topic Another plasma component...

JTknives wrote: When I try and jog any of the axis I get a “joint # fallowing error” where the # corasponds to x=0 y=1 and z=2. Also the control trips out and has to be turned back on.


Are you running a metric machine? Form memory one of the pncconf defaults is wrong for metric and will cause that. I've just forgotten the exact details. Maybe ask in another section where more people (and PCW) will see it.
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
09 May 2019 20:47 - 09 May 2019 20:50 #133288 by Grotius
Replied by Grotius on topic Another plasma component...
Mostly of time a following error can be solved by the ferror factor. Just attached a example to solve this. It works for servo (PID) and stepper systems. Interface type indepenent.
[AXIS_X]
MIN_LIMIT = -10000
MAX_LIMIT = 6560
MAX_VELOCITY = 160
MAX_ACCELERATION = 350

[JOINT_0]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 160
MAX_ACCELERATION = 350
STEPGEN_MAXACCEL = 750
SCALE = 187.25

# You see over here Ferror and Min_ferror. They are important to avoid following error's.
FERROR = 1
MIN_FERROR = .25

MIN_LIMIT = -10000
MAX_LIMIT = 6560
#HOME_LATCH_VEL = -1
#HOME_SEARCH_VEL = -20
#HOME_FINAL_VEL = -1
#HOME_IGNORE_LIMITS = YES
#HOME_OFFSET = -2
#HOME_SEQUENCE = -2

HOME_LATCH_VEL = 0
HOME_SEARCH_VEL = 0
HOME_FINAL_VEL = 0
HOME_IGNORE_LIMITS = YES
HOME_OFFSET = 0
HOME_SEQUENCE = 0
Last edit: 09 May 2019 20:50 by Grotius.
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
09 May 2019 20:59 #133293 by rodw
Replied by rodw on topic Another plasma component...

Grotius wrote: Mostly of time a following error can be solved by the ferror factor. Just attached a example to solve this. It works for servo (PID) and stepper systems. Interface type indepenent.


Thats the one I was trying to remember!

Please Log in or Create an account to join the conversation.

More
09 May 2019 21:36 #133301 by Dee436
Replied by Dee436 on topic Another plasma component...
The joint following error on metric machines was the following setting, I had the same issue
"setp pid.N.maxerror .0005"

It’s obviously defaulted for imperial but way too small for metric
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
09 May 2019 22:08 #133303 by Uthayne
Replied by Uthayne on topic Another plasma component...

phillc54 wrote: I pushed another update:
- remove duplicated ini file entry - doesn't really affect anything, just a tidy up
- change resolution for arc voltage input scaling and offset
GUI files changed are:
configs/sim/axis/plasmac/native/plasmac_axis.py
configs/sim/axis/plasmac/gladevcp/plasmac_panel.py
configs/sim/gmoccapy/plasmac/plasmac_config.py
configs/sim/gmoccapy/plasmac/plasmac_panel.py


rodw wrote:
The on screen scaling does not work because of enforced upper and lower limits in the config screen as I can't enter an offset of 3659.375 (0-100 enforced)

Also the maths in my earlier post says the frequency counts per volt is 83.73 and you have to input the reciprocal of this which is 0.011943151 which is not logical. So I would recommend that the maths be changed to do the reciprocal stuff internally and also remove the enforced range on the scale. If that was the case I think it would work well with some explanation in the docs.

I have fixed the upper and lower limits, hopefully by enough to cover everything.
I don't want to change too much as I don't want the component itself to be dependent on any particular hardware.

I rigged up a 7i76e with a TCAD connected to the encoder input and two batteries for testing:
- run LinuxCNC
- open halshow and watch plasmac.arc-voltage-in and plasmac.arc-voltage-out
- set arc-voltage-scale to 1
- set arc-voltage-offset to the value read from plasmac.arc-voltage-in
- measure battery voltage
- connect battery to THCAD input
- set arc-voltage-scale to battery-voltage / plasmac.arc-voltage-out
could probably fine tune further but it was good enough for the purpose of the exercise.
My values were:
arc-voltage-offset = -3805
arc-voltage-scale = -0.000406

Cheers, Phill.


Im using a THCAD-300 which requires a voltage offset of 118200. I saw the max (upper) value on the arc-voltage-offset was 99999, so I had to increase it to 120000 so I could set my offset correctly. I realize that range isn't an issue for the THCAD-10s, but I assume anybody else with - 300 would run into the same issue.

Please Log in or Create an account to join the conversation.

More
09 May 2019 22:15 #133304 by Grotius
Replied by Grotius on topic Another plasma component...
@Bryan,

Has your THCAD-300 has jumpers on it? Then you can go a step back in scale to provide more full scale to linuxcnc. (= evolves in less accuracy, but no problem i think ).

OUTPUT FREQUENCY
The THCAD's frequency output can be optionally divi
ded by 32, 64, or 128 for
applications where the frequency is counted by soft
ware. Output frequency is selected by
placing a shorting jumper on one of 4 sets of pins.
Default mode is divide by one. The
calibration data on the THCAD is recorded in the di
vide by one mode..

www.mesanet.com/pdf/analog/thcadman.pdf
The following user(s) said Thank You: phillc54, Uthayne

Please Log in or Create an account to join the conversation.

More
09 May 2019 23:10 #133306 by rodw
Replied by rodw on topic Another plasma component...

Uthayne wrote: Im using a THCAD-300 which requires a voltage offset of 118200. I saw the max (upper) value on the arc-voltage-offset was 99999, so I had to increase it to 120000 so I could set my offset correctly. I realize that range isn't an issue for the THCAD-10s, but I assume anybody else with - 300 would run into the same issue.


Yes, Grotius is on the money. The recommended setting is to set the THCAD to the 1/32 divide setting. Then you offset is only 3694.
By using this frequency divider, you get better accuracy as the THCAD has more time to average the results.
The following user(s) said Thank You: phillc54, Uthayne

Please Log in or Create an account to join the conversation.

More
09 May 2019 23:30 #133308 by Uthayne
Replied by Uthayne on topic Another plasma component...

rodw wrote:
Yes, Grotius is on the money. The recommended setting is to set the THCAD to the 1/32 divide setting. Then you offset is only 3694.
By using this frequency divider, you get better accuracy as the THCAD has more time to average the results.


Ah, good points. Thanks Grotius and rodw.

Is there any benefit to switching it out for the -10 model? Was previously using it with raw arc voltage, now using it on a Hypertherm and could use divided voltage straight from the CPC

Please Log in or Create an account to join the conversation.

Time to create page: 0.126 seconds
Powered by Kunena Forum