Why is Plasmac and QTplasmac pausing at the end of a cut for no reason?

More
20 Jun 2021 01:39 #212458 by phillc54

Really strange I don't get updates despite bring subscribed to this thread.

Me either, for any thread or even for the PlasmaC section. :(
I am getting tired of checking the forum manually...

Please Log in or Create an account to join the conversation.

More
20 Jun 2021 16:08 #212496 by snowgoer540

Really strange I don't get updates despite bring subscribed to this thread.

Me either, for any thread or even for the PlasmaC section. :(
I am getting tired of checking the forum manually...


I stopped getting emails as well... :pinch:

Please Log in or Create an account to join the conversation.

More
22 Jun 2021 08:33 #212654 by phillc54

There is still the issues that render QTplasmac unusable. Eg. cycle start issue mentioned earlier. To me thats a worry when the one that works for me is depreciated.


Did you ever sort this out?

Please Log in or Create an account to join the conversation.

More
23 Jun 2021 09:18 #212726 by rodw

There is still the issues that render QTplasmac unusable. Eg. cycle start issue mentioned earlier. To me thats a worry when the one that works for me is depreciated.


Did you ever sort this out?


No have not looked at it!

Please Log in or Create an account to join the conversation.

More
23 Jun 2021 10:41 #212727 by phillc54

There is still the issues that render QTplasmac unusable. Eg. cycle start issue mentioned earlier. To me thats a worry when the one that works for me is depreciated.

Did you ever sort this out?

No have not looked at it!


If you have a pendant and or external buttons then it may be related to some of the hal nets that qtplasmac needs. I have recently pushed some hal pins that allow a pendant to be more easily connected.

linuxcnc.org/docs/devel/html/plasma/qtpl....html#qt_ext-hal-pin

Please Log in or Create an account to join the conversation.

More
24 Jun 2021 07:49 #212791 by rodw
Plasmac should not be fighting with the dedicated Mesa MPG inputs surely? That side of it was working.

I did see that. I might review some of the early red/yellow/green/flash code we did. Those pins could be handy.. I have not been using the pendant buttons for motion start but they are probably connected.

Please Log in or Create an account to join the conversation.

More
24 Jun 2021 07:57 #212792 by phillc54

Plasmac should not be fighting with the dedicated Mesa MPG inputs surely?

No, it has nothing to do with MPG, I wasn't suggesting that. I was looking more towards is-idle, is-paused etc. I am only guessing because I haven't seen your config.

Please Log in or Create an account to join the conversation.

More
20 Jul 2021 02:52 #215362 by rodw

MX-Linux has the preempt kernel in the standard packages so it can be easily installed from synaptic or apt.
 

Any more clues on this? I've installed MX Linux  MX-19.4.1_x64 “ahs”
But can't find anything about preempt_rt in Synaptic
What should I look for?

Please Log in or Create an account to join the conversation.

More
20 Jul 2021 03:12 #215363 by phillc54
Attachments:

Please Log in or Create an account to join the conversation.

More
20 Jul 2021 03:53 #215366 by rodw
Thanks Phil, That worked but the next challenge is installing the key without a user ID
$ sudo apt-key adv --keyserver hkp://keys.openpgp.org:80 --recv-key EF1B07FEE0EE663E
Executing: /tmp/apt-key-gpghome.VIuCqsavWb/gpg.1.sh --keyserver hkp://keys.openpgp.org:80 --recv-key EF1B07FEE0EE663E
gpg: key EF1B07FEE0EE663E: new key but contains no user ID - skipped
gpg: Total number processed: 1
gpg:           w/o user IDs: 1

This must be new. Any ideas?

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.172 seconds
Powered by Kunena Forum