Why is Plasmac and QTplasmac pausing at the end of a cut for no reason?

More
11 Jun 2021 14:05 #211804 by snowgoer540

I know this is all off topic to Rod’s problem, but here is the aforementioned post:

forum.linuxcnc.org/qtvcp/41514-inconsistent-error-messages


Offtopic but relevant cos I don't see any popups either. I do in Gmoccapy.

I might revert to the standard ISO. I just hate the desktop! So unfriendly.

I also have lost the touch screen that just installed on 17.3 out of the box.


Phill pointed me to MX Linux. So far I have zero complaints. I always had WiFi issues with the stock iso. Plus the error popups work :laugh:

Please Log in or Create an account to join the conversation.

More
11 Jun 2021 23:56 #211835 by rodw


Phill pointed me to MX Linux. So far I have zero complaints. I always had WiFi issues with the stock iso. Plus the error popups work :laugh:


Can you still use Tommy's method to apply the PREEMPT_RT patch?

Please Log in or Create an account to join the conversation.

More
12 Jun 2021 01:08 - 12 Jun 2021 01:08 #211838 by snowgoer540


Phill pointed me to MX Linux. So far I have zero complaints. I always had WiFi issues with the stock iso. Plus the error popups work :laugh:


Can you still use Tommy's method to apply the PREEMPT_RT patch?


I’m not familiar with Tommy’s method to be honest so I can’t say.

But after using a base MX Linux 19.3 iso it was as easy as installing the appropriate LCNC kernel, the LinuxCNC and Qtvcp dependencies, building linuxcnc (I use RIP), etc. I would reckon it’s even easier with a package build. I just use RIP so I can poke at the source code if I run into any issues and help diagnose the issue. Plus I don’t have to wait on the buildbot. Otherwise package builds are probably easier.

I am away at the moment, or I could provide you more detailed guidance. I have notes from when I switched over. Probably be early next week until I could shoot some notes over.
Last edit: 12 Jun 2021 01:08 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
12 Jun 2021 10:29 #211862 by tommylight
Chances are the howto for Mint 19.3 will work for MX also, but i never tested it.

Please Log in or Create an account to join the conversation.

More
12 Jun 2021 10:49 #211866 by phillc54
MX-Linux has the preempt kernel in the standard packages so it can be easily installed from synaptic or apt.
The standard desktop is xfce but there are some extra tools that make admin a lot easier. Other desktops are available.
It is quite snappy as well as it doesn't run the systemd bloatware as standard although it is an option.
The following user(s) said Thank You: tommylight, rodw

Please Log in or Create an account to join the conversation.

More
12 Jun 2021 17:50 #211877 by rodw

MX-Linux has the preempt kernel in the standard packages so it can be easily installed from synaptic or apt.
.


Thanks that was the missing piece of info :)

Please Log in or Create an account to join the conversation.

More
12 Jun 2021 18:52 #211880 by snowgoer540
Sorry. Like I say, out of pocket for a bit.

Please Log in or Create an account to join the conversation.

More
12 Jun 2021 23:31 #211905 by crowloy
I found that I was getting a Limit switch error on Joint 2 all the time while cutting. I had to add a dbouce to the limit switches on my machine. When the limit switch was toggled, it was always on joint 2 (Y2 axis) and caused the machine to stop requiring a PowerOn, and then I was able to continue.I'm using hall effect sensors for my X,Y,Y2 sensors.
The following user(s) said Thank You: phillc54

Please Log in or Create an account to join the conversation.

More
14 Jun 2021 00:12 #211979 by rodw
Well this is a plot of the end of a cut. There is a 0.5 sec delay from when motion stops until the torch enable (spinea) signal goes off.


A sample file is attached. If anyone has a pizza oven, here is your chance to make an ember scraper for it :)

I checked all the debounces and they are set to 5 so way less than what we see here.
This has not ben an issue before like this
Could it be the M67 before M5 causing the delay?
Using the Sheetcam post processor.
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Jun 2021 00:27 #211980 by tommylight

Could it be the M67 before M5 causing the delay?

M67 ?
Pretty sure it works in conjunction with motion, so if using it for torch on, i would change that promptly.
Or was it M68 ???

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.139 seconds
Powered by Kunena Forum