Material Settings Glitch

More
11 Jun 2020 01:29 #171045 by tommylight
Replied by tommylight on topic Material Settings Glitch

So thanks again to all involved. I feel that doesn’t get said enough.

It does not, that is why i tend to say as often as i can, even when not needed.
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 01:29 #171046 by rodw
Replied by rodw on topic Material Settings Glitch

So what tools do you have in sheetcam? I think a lot of problems would be solved if you deleted your plasmac tool file and ran the materialverter so it agreed with sheetcam.


To be candid, I didn’t know the materialverter was a thing. I’m open to suggestion for work flow for sure. Sheetcam is very new to me.


The materialverter is a pythong script inlcuded with PLasmac that takes the cut charts in Sheetcam and converts them to PLasmac format. YOu should be able to find the standard cut charts for your 45xp for sheetcam.

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 01:33 - 11 Jun 2020 01:34 #171049 by snowgoer540

So what tools do you have in sheetcam? I think a lot of problems would be solved if you deleted your plasmac tool file and ran the materialverter so it agreed with sheetcam.


To be candid, I didn’t know the materialverter was a thing. I’m open to suggestion for work flow for sure. Sheetcam is very new to me.


The materialverter is a pythong script inlcuded with PLasmac that takes the cut charts in Sheetcam and converts them to PLasmac format. YOu should be able to find the standard cut charts for your 45xp for sheetcam.


All the ones I found (candcnc has some) didn’t match the cut chart that came with my hypertherm (65XP). Also, I’ve noticed that the cut charts in the 45XP manual don’t match the 45A cut charts in the 65XP manual, which doesn’t make sense to me since they’re the same consumables and torch...

Edit: I planned to do them all from the 65XP manual and upload them here in the PP area once I get time.
Last edit: 11 Jun 2020 01:34 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 01:34 - 11 Jun 2020 01:35 #171050 by phillc54
Replied by phillc54 on topic Material Settings Glitch
Your posted gcode and materials work fine here on a sim. Have you tried without line numbers.
Here is a copy with the line numbers stripped out.
Attachments:
Last edit: 11 Jun 2020 01:35 by phillc54.

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 01:36 - 11 Jun 2020 01:36 #171052 by snowgoer540

You posted gcode and materials work fine here on a sim. Have you tried without line numbers.
Here is a copy with the line numbers stripped out.


I have not, thank you for the stripped version, I’ll give it a go tomorrow.

Could it have anything to do with 2.9? I only ask because it seems to come up around pauses motion, or am I just perceiving it wrong?
Last edit: 11 Jun 2020 01:36 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 02:18 #171065 by phillc54
Replied by phillc54 on topic Material Settings Glitch

Could it have anything to do with 2.9? I only ask because it seems to come up around pauses motion, or am I just perceiving it wrong?


No idea. I do all the development and testing on 2.8 and only run 2.8 on my machines. I only ever test on master if there appears to be an issue with master that someone has found.

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 03:31 #171069 by rodw
Replied by rodw on topic Material Settings Glitch
I'v always used master back when master was 2.8 But it was said it had problems and dangerous until this was fixed
github.com/LinuxCNC/linuxcnc/issues/865
So now it has so maybe its OK Now.

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 04:52 - 11 Jun 2020 04:53 #171074 by phillc54
Replied by phillc54 on topic Material Settings Glitch
I did a bit of an experiment and set up a material file with 100 materials and wrote a little gcode routine that did six material changes with only a 0.01 second wait for M66 then tested for the correct material after the wait and it passed with flying colours. So at least I don't think your issue is a timing one as you have a 2 second wait. It even passed on the Pi4 as well.
Attachments:
Last edit: 11 Jun 2020 04:53 by phillc54.
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 10:31 #171108 by snowgoer540

I did a bit of an experiment and set up a material file with 100 materials and wrote a little gcode routine that did six material changes with only a 0.01 second wait for M66 then tested for the correct material after the wait and it passed with flying colours. So at least I don't think your issue is a timing one as you have a 2 second wait. It even passed on the Pi4 as well.


Any chance you could attach the materials file too? I could give your experiment a go on my machine, see what happens.

If I understood correctly though, this could still all be just related to the fact that I had line numbers?

Please Log in or Create an account to join the conversation.

More
11 Jun 2020 10:32 #171109 by snowgoer540

I'v always used master back when master was 2.8 But it was said it had problems and dangerous until this was fixed
github.com/LinuxCNC/linuxcnc/issues/865
So now it has so maybe its OK Now.


Yikes. Maybe I need to stop being lazy and set up 2.8.

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.216 seconds
Powered by Kunena Forum