Feature Request

More
25 Jul 2020 22:43 #175803 by phillc54
Replied by phillc54 on topic Feature Request

If you are going to ignore arc Ok behaviour, why insist on it at the beginning of the cut?

Because that is the easiest way (for me) to begin testing this feature...

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 22:44 #175804 by tommylight
Replied by tommylight on topic Feature Request
hmm i am lost, again ......

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 22:47 #175805 by phillc54
Replied by phillc54 on topic Feature Request

EDIT2: Not sure if it's related, but I cant get Cut Recovery to come up when it's paused anymore either

Were you using the cut-recovery branch?


Also, I was talking to CBEAR tonight, and he noticed that the change consumables button no longer works. If you pause a NC file (during a rapid, etc), and try to jog, you get a bunch of trajectory errors. Further, if you press Change Consumables, nothing happens.
EDIT: I got this to work as well. It moved all the way to the X home position (no other axis which I think is normal). Everything worked as it was, but I also experience where it didnt work at all.
EDIT2: If I pause it at the end of a rapid move, prior to where the M3 is, then change consumables doesnt work anymore.

I assume this is 2/.8/master. I will have a look.

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 23:16 #175812 by snowgoer540
Replied by snowgoer540 on topic Feature Request

Were you using the cut-recovery branch?

Yea, I'd like to tell you I switched over to the mesh test branch, but I didnt have time today. Hopefully tomorrow.

I assume this is 2/.8/master. I will have a look.

2.8, I am off master as the Lead Developer said he develops to 2.8.

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 23:33 #175819 by phillc54
Replied by phillc54 on topic Feature Request

Also, I was talking to CBEAR tonight, and he noticed that the change consumables button no longer works. If you pause a NC file (during a rapid, etc), and try to jog, you get a bunch of trajectory errors. Further, if you press Change Consumables, nothing happens.
EDIT: I got this to work as well. It moved all the way to the X home position (no other axis which I think is normal). Everything worked as it was, but I also experience where it didnt work at all.
EDIT2: If I pause it at the end of a rapid move, prior to where the M3 is, then change consumables doesnt work anymore.

Good catch. Pausing during a rapid doesn't allow Change Consumables nor does it allow Paused Motion. Looks like that has always been the case. I probably never thought to test that scenario... :(

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 23:37 #175821 by snowgoer540
Replied by snowgoer540 on topic Feature Request

Good catch. Pausing during a rapid doesn't allow Change Consumables nor does it allow Paused Motion. Looks like that has always been the case. I probably never thought to test that scenario... :(


I suppose this gives me job security :)

I wish I could find the steps to reproduce what causes the motion to lock up sometimes. Bugs me when I can't consistently break something :lol:

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 23:49 #175826 by tommylight
Replied by tommylight on topic Feature Request

I wish I could find the steps to reproduce what causes the motion to lock up sometimes.

Been there, could not reproduce it, luckily happened twice in a day and once the next day, but never again.
I was testing Z axis, so point your attention in that direction while destroy.... testing things ! :)

Please Log in or Create an account to join the conversation.

More
25 Jul 2020 23:59 #175828 by snowgoer540
Replied by snowgoer540 on topic Feature Request

I was testing Z axis


Now that you say that... gives me an idea of something I might have done.

The more I destroy, the less anyone else has to?:evil: :laugh:
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
26 Jul 2020 08:07 #175866 by phillc54
Replied by phillc54 on topic Feature Request

I didnt get to do any testing today, the mill took up all of my time, but I did try F9 and jogging, and discovered that I still have the issue where I cant jog anymore after I press escape to stop the torch. The arrow keys instead select the X Y or Z axis highlight in the touch off/homing area. No amount of clicking makes it go away. I have to kill LinuxCNC and start over to get it back.
EDIT: I cant get it to do it again, I was trying to find the exact steps to reproduce, it seems to be intermittent, which I know is the worst kind.
EDIT2: Not sure if it's related, but I cant get Cut Recovery to come up when it's paused anymore either :(


Also, I was talking to CBEAR tonight, and he noticed that the change consumables button no longer works. If you pause a NC file (during a rapid, etc), and try to jog, you get a bunch of trajectory errors. Further, if you press Change Consumables, nothing happens.
EDIT: I got this to work as well. It moved all the way to the X home position (no other axis which I think is normal). Everything worked as it was, but I also experience where it didnt work at all.
EDIT2: If I pause it at the end of a rapid move, prior to where the M3 is, then change consumables doesnt work anymore.

I just pushed a few fixes that will hopefuly sort this out...
I also saw during testing this stuff that the breakaway didn't work during rapids, that should be sorted as well.

Please Log in or Create an account to join the conversation.

More
26 Jul 2020 08:21 #175868 by rodw
Replied by rodw on topic Feature Request
I was thinking today another use for disabling ArcOK would be when severing a sheet. Its easy to get a valid probe on the edge of a sheet is easy but its hard to line the torch up exactly to void having to slit a mm or so with an angle grinder. If ArcOK was disabled, you could start a mm or so off the sheet and still sever it happily. (my shield is about 12mm in diameter with a flat bottom so its hard to line up by eye..)
The following user(s) said Thank You: snowgoer540

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.110 seconds
Powered by Kunena Forum