wrong scale thc of the z axis during cutting on qtplasmac

More
21 Jul 2021 16:24 #215502 by snowgoer540
1. Can you post a backup of your config (created from the parameters tab)?  

2. At a minimum, if you can’t post the backup, can you tell us what version of QtPlasmaC are you on?  (It’s in the header of the program window)
 

Please Log in or Create an account to join the conversation.

More
21 Jul 2021 19:08 #215517 by billykid
Thanks but for now I have given up on that configuration. I made a new one with pncconf it seems to work but the pid with the usual parameters gives following errors .. after checking it better. the mesa is a 7i80db16 in pncconf there is not ... only the 7i80hd with the pwm I need, but the pins are the same I think.

Please Log in or Create an account to join the conversation.

More
22 Jul 2021 09:18 - 22 Jul 2021 09:23 #215557 by billykid
This is the new configuration, it is much better but thc problem remains .. here I have the backup
latency error doesn't matter.
Thanks in advance
Attachments:
Last edit: 22 Jul 2021 09:23 by billykid.

Please Log in or Create an account to join the conversation.

More
22 Jul 2021 10:24 - 22 Jul 2021 11:30 #215558 by snowgoer540

This is the new configuration, it is much better but thc problem remains .. here I have the backup
latency error doesn't matter.
Thanks in advance


Your machine is a metric machine, so setting plasmac.thc-feed-rate to 100 is setting it to 100mm/min.  That is incredibly slow, so slow that I am surprised you consider it to be "working".  Especially when your Z axis is capable of 1500mm/min.

I see that your P and I gains are set to 500.  You should not have to set them that high, but in your case you do, because you set the plasmac.thc-feed-rate pin to 100.  

Try the following:
1. Delete plasmac.thc-feed-rate 100 from qtplasma2.hal.  
2. Open QtPlasmaC
3. Open HalMeter from the parameters tab
4. Look for plasmac.thc-feed-rate
5. Take a screen shot and post it here/report what value the pin is set to 

Depending what the results of 5 are, I will also recommend the following:
6. Change your P gain back to the default value of 10.  I've seen people report needing to set this to 20 to have it work to their satisfaction.  Most of us use the default value with 0 issues. 
7. Change your I gain back to the default value of 0

I also see that you don't use Auto Volts.  You might give that a try.  It can make things way easier as it takes away the need to guess at voltages for different materials. 
Last edit: 22 Jul 2021 11:30 by snowgoer540. Reason: fix units.
The following user(s) said Thank You: billykid

Please Log in or Create an account to join the conversation.

More
22 Jul 2021 11:00 #215560 by billykid
I said that everything works better but not the thc

the plasmac.thc-feed-rate parameter is always at zero even during cutting, I supply arc voltage with a power supply when the voltage is 0 and at 100 volts it marks 100 perfectly

Please Log in or Create an account to join the conversation.

More
22 Jul 2021 11:04 #215561 by phillc54
It should be set by the GUI, can you run the config from a terminal and see if there are any error messages related to it. In your case it should be set to 1500.

Please Log in or Create an account to join the conversation.

More
22 Jul 2021 11:29 #215563 by billykid
uhm .. the plasmac.thc-feed-rate parameter has no links in hal..it did so pncconf i didn't touch anything.

Please Log in or Create an account to join the conversation.

More
22 Jul 2021 11:50 - 22 Jul 2021 11:51 #215565 by snowgoer540
Perhaps I am missing something.

This is from qtplasma2.hal in the backup you posted:
#*******************
# AXIS X JOINT 0
#*******************
setp plasmac.thc-feed-rate 100
setp pid.x.Pgain [JOINT_0]P
setp pid.x.Igain [JOINT_0]I
setp pid.x.Dgain [JOINT_0]D
setp pid.x.bias [JOINT_0]BIAS
setp pid.x.FF0 [JOINT_0]FF0
setp pid.x.FF1 [JOINT_0]FF1
setp pid.x.FF2 [JOINT_0]FF2
setp pid.x.deadband [JOINT_0]DEADBAND
setp pid.x.maxoutput [JOINT_0]MAX_OUTPUT
setp pid.x.error-previous-target true

as such, plasmac.thc-feed-rate is set in the qtplasma2.hal file. Were you suggesting pncconf added that? I thought you said earlier that you added it manually?
Last edit: 22 Jul 2021 11:51 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
22 Jul 2021 11:59 - 22 Jul 2021 12:02 #215566 by billykid
that I had added but only that I have not changed anything else

sorry I have the wrong file for half an hour, anyway since you said to remove it I removed it immediately. it seems to me that this parameter is not related to anything in hal.
Last edit: 22 Jul 2021 12:02 by billykid.

Please Log in or Create an account to join the conversation.

More
22 Jul 2021 12:01 #215567 by phillc54

uhm .. the plasmac.thc-feed-rate parameter has no links in hal..it did so pncconf i didn't touch anything.

No. there is no hal net. It is set directly from the python handler file:
github.com/LinuxCNC/linuxcnc/blob/master...smac_handler.py#L174

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.088 seconds
Powered by Kunena Forum