New Project with Mesa 7I96 and THCAD-05

More
30 Jun 2021 11:23 - 01 Jul 2021 09:06 #213331 by bevins
You are going to need HOME_IGNORE_LIMITS = YES in the ini or else it will think it hit a limit when you home.
Last edit: 01 Jul 2021 09:06 by bevins.

Please Log in or Create an account to join the conversation.

More
30 Jun 2021 11:34 #213333 by phillc54

You are going to need HOME_IGNORE_LIMITS = 1 in the ini or else it will think it hit a limit when you home.

That shows another issue with PnCconf, I will fix that one tomorrow.

Please Log in or Create an account to join the conversation.

More
30 Jun 2021 21:25 #213375 by acourtjester
Hi PhillC
With your help I have made some good progress today, no where near where I need to be but, I actually felt positive. I rewired the 3 axis home switches to single pin inputs for each and tried to use the axis limit + home but it would trip the limit when moving on the switch. So I have it set now with home only for each axis. I am only working with the Z as it is easy to push the switch. I was puzzled why it homed in the wrong direction while moving correctly with the arrow key. After looking over the info in the homing lay out I found this. The direction of the back-off is opposite the sign of HOME_SEARCH_VEL.
I removed the – from the value in the INI and it changed directions and looks like it work correctly. It does get an error if the home switch is pushed to quickly no problem something for later.
I did make the changes of the Net all-limit-home, but it did not seem to work so I changed it back to what it was. I had to change the home switches for NO so they would not error at start up. The diagram I had looked like they should be NC but I could be wrong.
I will be working on the motor calibration next.
If you don't mind I will have more questions.
I did notice that in Hal show the names change due to what conditions are set in the Pncconf.

You are going to need HOME_IGNORE_LIMITS = 1 in the ini or else it will think it hit a limit when you home.
Maybe that that is why I had a problem
 

File Attachment:

File Name: PhillC2.zip
File Size:5 KB

 
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Jun 2021 23:22 #213393 by phillc54

I did make the changes of the Net all-limit-home, but it did not seem to work so I changed it back to what it was. I had to change the home switches for NO so they would not error at start up. The diagram I had looked like they should be NC but I could be wrong.

You probably need to invert the inputs, you can do it in PnCconf by checking the Inv box next to the GPIO Input box or you can do it manuually in the hal file by changing from:
net home-z     <=  hm2_7i76e.0.7i76.0.0.input-15
to:
net home-z     <=  hm2_7i76e.0.7i76.0.0.input-15-not
You will need the HOME_IGNORE_LIMITS=1 in each joint that shares a home and limit switch.

Please Log in or Create an account to join the conversation.

More
01 Jul 2021 00:39 - 01 Jul 2021 00:48 #213395 by acourtjester
There is a small check box in the Z section of the Pncconf that did the invert for the Z direction. I think is said inv motor, it is in the lower left of the page you put in the step number.
It is working correctly now just the limit part for each axis, but I'm not sure if it is needed.
I did try the not addition but did not have the - in front of the not so it errored out.
Thanks for showing the correct syntax for that addition
I assume the HOME_IGNORE_LIMITS=1 is placed in the joint section of the INI for each axis.
Last edit: 01 Jul 2021 00:48 by acourtjester. Reason: adding info

Please Log in or Create an account to join the conversation.

More
01 Jul 2021 01:02 #213399 by phillc54

I assume the HOME_IGNORE_LIMITS=1 is placed in the joint section of the INI for each axis.

Yes, for every joint that has a shared home/limit switch.
 

Please Log in or Create an account to join the conversation.

More
02 Jul 2021 19:52 - 02 Jul 2021 19:57 #213507 by acourtjester
I made the changes in the Pncconf to have both limits and home for the 3 axis. It does work, but the operation (pointed to) in the attached image does not for each of the axis. I moves toward the home, I trip the switch and it stops moving then continues in the same direct slower. When I hit the switch again it backs off and sets the DRO to 0.0.   I have tried changing or adding lines in the INI, but cannot make the first back off the switch work.
 
I am also getting the attached error randomly which seem to be for no reason I can connect
 

Another problem is the axis move very slowly I built 8 tables using the exact same drivers, motor, and gearing for each axis.  I have change the switch selections for different steps per rev (this only changes the calculations for the steps per inch).  The only difference is the software, I have used Mach and UCCNC on the others, this is the first Linuxcnc.
Note in passing here is a picture of my other table with the new tables moving assembly mounted for testing with the new controller and linuxcnc.
 
Attachments:
Last edit: 02 Jul 2021 19:57 by acourtjester. Reason: adding info

Please Log in or Create an account to join the conversation.

More
02 Jul 2021 20:30 #213508 by rodw
A couple of things. 
1. Home switches MUST remain triggered all the way to the end of travel
2. If using a mechanical switch, you may need to use the debounce component. Its possible that contact bounce causes the back off to be registered prematurely. See linuxcnc.org/docs/devel/html/man/man9/dbounce.9.html
I don't think you can do that in pncconf. It is time to leave it behind
I will say it can be hard to see the movements.
3. In your ini file [TRAJ] section, DEFAULT_LINEAR_VELOCITY  sets the jogging rate in inches/second. See
linuxcnc.org/docs/devel/html/config/ini-...g.html#_traj_section

Please check these settings in your ini file for each joint and heed the comments
# The values below should be 25% larger than MAX_VELOCITY and MAX_ACCELERATION
# If using BACKLASH compensation STEPGEN_MAXACCEL should be 100% larger.
STEPGEN_MAXVEL = 700
STEPGEN_MAXACCEL = 2000

I did find that it was pretty easy to migrate the velocities accelerations and steps per settings of Mach when I helped another user recently.
 

Please Log in or Create an account to join the conversation.

More
02 Jul 2021 21:39 #213511 by acourtjester
Thanks for the reply I had used the same steps settings that I had for the other table.
This is what is in mine
STEPGEN_MAXVEL = 6.25
STEPGEN_MAXACCEL = 2.12

Please Log in or Create an account to join the conversation.

More
02 Jul 2021 21:50 #213512 by Clive S

I made the changes in the Pncconf to have both limits and home for the 3 axis. It does work, but the operation (pointed to) in the attached image does not for each of the axis. I moves toward the home, I trip the switch and it stops moving then continues in the same direct slower. When I hit the switch again it backs off and sets the DRO to 0.0.   I have tried changing or adding lines in the INI, but cannot make the first back off the switch work.

Do you have something like this in the ini file

HOME = 30
HOME_OFFSET = 0
HOME_SEARCH_VEL = -50 This is the speed to search for the switch changing the sign will reverse the direction
HOME_LATCH_VEL = 1 The same with this so if HOME_SEARCH_VEL is -ve  make the HOME_LATCH_VEL +ve to back off the switch
HOME_FINAL_VEL = 50
 

Please Log in or Create an account to join the conversation.

Time to create page: 0.268 seconds
Powered by Kunena Forum