New Project with Mesa 7I96 and THCAD-05

More
24 Jul 2021 17:17 #215795 by acourtjester
OK great day in the Hood  I have good looking numbers in both encoder velocities.  And I do see a change when I touch a 9 volts battery to the Arc Voltage wires. Now as to the "E stop" I will let that go for now I can parallele the "e stop switch" with a home/limit switch as pushing any with drop the power so works the same.   I will check the wires for the Ohmic touch as I don't see any indication when I click on the switch I install to simulate the torch touching metal.
I may be reading to much into these things, I do not see anything in the Volts display on the main screen, nor do I see the Arc OK light lite.  But I do see the Arc OK light switch in Hal Show??  Are there other conditions that need to be met for these displays to show up?? Like actually running a cut operation?
As usual the member of this forum have directed me farther on the road to a functions operation and I do thank each of you.  YEAH
 
 
 

 
Attachments:

Please Log in or Create an account to join the conversation.

More
24 Jul 2021 20:07 #215804 by rodw
Great work Tom!

ArcOK will only light if you are cutting and an input is connected correctly in Hal

We need to regroup now before doing any more. Can you  create a a back up of your config using the button on the Parameters tab and upload the zip file here?

Not much further to go.
We need some information to get you sorted.
1. Details from THCAD-10 calibration sticker
2. Details from THCAD-5 calibration sticker
3. Input pin for your float switch
4. Output pin you are using to turn the torch on (are you using a external relay or the 7i76e spindle relay)
5. Input pin you are using for your estop button.

Please Log in or Create an account to join the conversation.

More
24 Jul 2021 22:19 #215808 by acourtjester
Ok Rod here is the info you asked for, Thanks   Tom

 

File Attachment:

File Name: toms_test.zip
File Size:3 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
24 Jul 2021 22:47 #215811 by rodw
Some of the information.
So with your estop connected to input pin 12 per your hal file (TB6-13 on the board)
and in your ini file set the estop mode to 2
Try the attached hal file to enable your estop
I'm doing this on my chromebook so I could have a bug or two.

You will still need to always press the on screen button to come out of estop but the external button should also work.
If you send me a backup as I asked, I'll do a bit more for you. We need to get your ohmic probing working...

From the look of your hal file your torch should come on if you home all and press the pulse torch button.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
24 Jul 2021 23:08 #215813 by acourtjester
thanks Rod I will give that a try the next time I an in the shop.
I see you added some lines to the file

Please Log in or Create an account to join the conversation.

More
24 Jul 2021 23:26 #215816 by phillc54
I don't see any arc voltage encoder in your hal file, it should have been selected in PnCconf as below:

Warning: Spoiler!
Attachments:

Please Log in or Create an account to join the conversation.

More
25 Jul 2021 00:11 #215822 by rodw

I don't see any arc voltage encoder in your hal file, it should have been selected in PnCconf as below:
 

Thats why we need all of Tom's config. I think he moved it to another hal file

Please Log in or Create an account to join the conversation.

More
25 Jul 2021 00:13 #215823 by phillc54
What would be the reason for that?

Please Log in or Create an account to join the conversation.

More
25 Jul 2021 00:17 #215824 by rodw

What would be the reason for that?
 

I don't know but if the encoders are both counting as reported in earlier screen dumps, its in the config somewhere.

Please Log in or Create an account to join the conversation.

More
25 Jul 2021 00:20 #215825 by phillc54
It kinda defeats the whole purpose of a machine hal and a custom hal.

Please Log in or Create an account to join the conversation.

Time to create page: 0.225 seconds
Powered by Kunena Forum